Project

General

Profile

Bug #9992

Greeter stays in English when Russian is selected

Added by mercedes508 almost 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
-
Start date:
08/13/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

In Tails 1.4 when russian is selected at Greeter, it switched to russian.
In Tails 1.5 when russian is selected at Greeter, it sticks t english.

That error unfortunately made it through the manuel test suite, we should maybe explicitly add it in the list of things to check when doing the internationalization tests.


Related issues

Duplicates Tails - Bug #11081: Adjust check_po to ignore more plural form errors Resolved 02/08/2016

History

#1 Updated by intrigeri almost 4 years ago

In Tails 1.4 when russian is selected at Greeter, it switched to russian.
In Tails 1.5 when russian is selected at Greeter, it sticks t english.

That's because the Russian translation is buggy and was therefore disabled.
I'm inclined to close this ticket, as we don't usually track Transifex translation issues here.

Next step is probably to get in touch with the last translators, point them to the problem (identified by check-po.sh), and hope someone will fix it some day.

#2 Updated by intrigeri almost 4 years ago

  • Assignee set to mercedes508
  • Type of work changed from Research to Communicate

#3 Updated by mercedes508 almost 4 years ago

  • Assignee changed from mercedes508 to intrigeri

I checked on Transifex, and I might be a fool but Russian is 100% translated and I didn't see where it's buggy. It looks like it didn't change since June 23rd.

I sent a message to the last translator in case that person knows what's wrong.

Any clue?

#4 Updated by mercedes508 almost 4 years ago

  • Type of work changed from Communicate to Research

#5 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to mercedes508

I checked on Transifex, and I might be a fool but Russian is 100% translated and I didn't see where it's buggy.

Thanks for checking, and no, you're not a fool :)

I wouldn't have noticed the problem myself manually, that's why we have automatic QA tools:

$ $TAILS_GIT/submodules/jenkins-tools/slaves/check_po 
W: ./ru/ru.po: incorrect-unused-plural-forms 'nplurals=4; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<=4 && (n%100<12 || n%100>14) ? 1 : n%10==0 || (n%10>=5 && n%10<=9) || (n%100>=11 && n%100<=14)? 2 : 3);' => 'nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;' or 'nplurals=4; plural=n==1 ? 3 : n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;'

#6 Updated by BitingBird over 3 years ago

Still the case in Tails Jessie.

#7 Updated by sajolida over 3 years ago

  • Subject changed from Greeter stays in english when russian is selected to Greeter stays in English when Russian is selected
  • Status changed from Confirmed to Duplicate
  • Assignee deleted (mercedes508)

That's due to a disagreement between i18nspector and Transifex on the plural form for Russian. I created #9992 to solve the root cause. Marking this one as a duplicate as it's more specific and I don't want to leave it with no assignee nor target version.

#8 Updated by sajolida over 3 years ago

  • Duplicates Bug #11081: Adjust check_po to ignore more plural form errors added

Also available in: Atom PDF