Project

General

Profile

Bug #9966

Remove references to .xsession-errors on Jessie

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/11/2015
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

This file isn't created/filled anymore. The logs now live in the journal. At least Tails Upgrader points users there, and should be updated.

Associated revisions

Revision 1c5deaca (diff)
Added by intrigeri over 3 years ago

Don't try to include .xession-errors in WhisperBack bug reports.

This file isn't created/filled anymore on Jessie. The logs now live in
the journal.

Refs: #9966

History

#3 Updated by intrigeri over 3 years ago

  • Subject changed from Remove references to .xession-errors on Jessie to Remove references to .xsession-errors on Jessie

#4 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

intrigeri wrote:

At least Tails Upgrader points users there, and should be updated.

I've verified that nothing else points to that file.

#5 Updated by intrigeri over 3 years ago

So, the upgrader points to ~/.xsession-errors on failure, because it currently has no means to display debugging info in its own GUI. And thus it prints debugging info on stdout/stderr, and that info lands into:

  • on Wheezy: ~/.xsession-errors which is user readable
  • on Jessie: into the systemd Journal (in Jessie) which can only be read by root, but is included in WhisperBack reports.

I've looked at the places where we point to .xsession-errors, and every time, either we can instruct the user to try something themselves, and then we do it (and generally we point to a dedicated doc page); or nobody but developers will be able to do much about the error anyway, so best would be to report a bug (and the report will include the debugging info by default) => IMO we should suggest to report a bug instead of pointing to ~/.xsession-errors. Still we need to be careful because some of these errors happen after we've disabled the network; in those cases a technical enough user would benefit from looking in the Journal instead of manually reporting a bug without the debugging info (since they can't use WhisperBack offline); let's assume that those people will quickly learn how to use journalctl if they didn't yet.

#6 Updated by intrigeri over 3 years ago

Actually the smallest possible change is to instruct to use sudo tails-debugging-info instead of ~/.xsession-errors. This works even without an admin password because WhisperBack needs it, at least until we run WhisperBack as a dedicated user.

#7 Updated by intrigeri over 3 years ago

  • % Done changed from 10 to 20

intrigeri wrote:

Actually the smallest possible change is to instruct to use sudo tails-debugging-info instead of ~/.xsession-errors. This works even without an admin password because WhisperBack needs it, at least until we run WhisperBack as a dedicated user.

Done in iuk.git:feature/jessie, commit 9c7d22992e236cc5750977c4e86bb4ed3fd01155.

#8 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 20 to 100

done in tails-iuk 1.27-1+jessie1

Also available in: Atom PDF