Project

General

Profile

Bug #9930

Create a Broadcom network adapters section on the known issues page

Added by mercedes508 over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
08/06/2015
Due date:
% Done:

100%

Feature Branch:
doc/9930
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

we should have a section in the known issues page that isn't about a specific broadcom hardware (as it is presently) but dedicated to every hardware that needs broadcom-sta-dkms package to work.

We could advertise that it might work in Tails, without MAC spoofing. Or simply won't work.

We should list a simple way for people to find by themselves if it can work:

  • If they can't boot Tails, how to determine their Wi-Fi model (from OSX, Windows, Linux)
  • If they can boot but can't use their Wi-Fi, how to determine their Wi-Fi model from Tails

Related issues

Related to Tails - Feature #7798: Support more Broadcom Wi-Fi chipsets Rejected 08/19/2014

Associated revisions

Revision 01d2add7
Added by sajolida about 4 years ago

Merge remote-tracking branch 'mercedes/doc/9930' (Closes: #9930)

Revision e696c4da
Added by sajolida about 4 years ago

Merge branch 'doc/9930' (Closes: #9930)

History

#1 Updated by mercedes508 over 4 years ago

  • Subject changed from Create a broadcom section in the known issues page to Create a broadcom network adapters section in the known issues page

#2 Updated by intrigeri over 4 years ago

  • Related to Feature #7798: Support more Broadcom Wi-Fi chipsets added

#3 Updated by intrigeri over 4 years ago

  • Subject changed from Create a broadcom network adapters section in the known issues page to Create a Broadcom network adapters section on the known issues page
  • Category set to Hardware support
  • Status changed from New to Confirmed

Just to refine a bit the scope of this ticket: is there any such hardware that prevents Tails from booting at all? I don't think I've ever heard of it.

#4 Updated by mercedes508 about 4 years ago

No I don't think such hardware prevents Tails from Booting.

Actually when I wrote the "if they can't boot..." I had in mind the case when something wants to try Tails for the very first time, and would like to know if the Wi-Fi card is going to work before trying it out. Which probably isn't worth making effort as the big deal is to have Tails to boot. The rest is always something you can workaround.

In the end it could simply be a few lines explaining how to identify the Wi-Fi card from Tails (lspci | grep Network) then linking to Debian Wi-Fi pages related to broadcom stuff so the users can determine which package it requires and find out by himself/herself that it might work under certain conditions (no MAC spoofing) or won't work at all (wl). And thus the point is mostly to make users do what frontdesk do for them :)

#5 Updated by mercedes508 about 4 years ago

  • Assignee changed from mercedes508 to sajolida
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA
  • Feature Branch set to mercedes508:doc/9930

I made a little draft to review from there:

mercedes508:doc/9930 b4e8e98

I changed the Other hardware issues section into Wireless section, because until now, it was only about one wireless issue, now two. And whenever we add others entries to that section which are not about Wi-Fi, it can easily come back to other hardware.

#6 Updated by sajolida about 4 years ago

  • Assignee changed from sajolida to mercedes508

Cool, I like the change from "Other hardware issues" to "Wireless section".

I did a whole bunch of rephrasing, simplifactions, etc. on top of your original text with b4e8e98..996af72. This time I felt too lazy to do a detailed review of nitpicking issues like this. But please have a look, try to see how stuff got improved, and tell me if you disagree with some of these changes. Then I'll merge it.

#7 Updated by sajolida about 4 years ago

  • Feature Branch changed from mercedes508:doc/9930 to doc/9930

#8 Updated by sajolida about 4 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 30 to 100

#9 Updated by intrigeri about 4 years ago

Added a7e03fe on top, see commit message to know why it not totally unimportant :)

I don't really understand the "as known as" part of "Some Broadcom wireless network adapters require the broadcom-sta-dkms Debian package as known as [wl](https://wiki.debian.org/wl) in order to possibly work while running Tails." I was going to rephrase it, but I don't even know what was the intended meaning. It can't be "also known as" because that would be untrue. The technical info you might need to improve over this is that broadcom-sta-dkms builds the wl kernel module (and ships its "source", FWIW).

#10 Updated by intrigeri about 4 years ago

  • Assignee deleted (mercedes508)
  • Target version set to Tails_1.6
  • QA Check changed from Ready for QA to Pass

(Adding milestone to ease reporting.)

#11 Updated by sajolida about 4 years ago

  • Assignee set to mercedes508
  • QA Check changed from Pass to Ready for QA

For some reasons, it seems like intrigeri did his review without seeing my previous changes because I already solved the phrasing issue around "as known as" in ce07173 and his commit created a conflict with my previous ones.

So I merged and pushed this again and assigning this for review by mercedes who's been the one to wrote the text initial, so I'd like to acknowledge whether my changes are correct.

#12 Updated by intrigeri about 4 years ago

For some reasons, it seems like intrigeri did his review without seeing my previous changes because I already solved the phrasing issue around "as known as" in ce07173 and his commit created a conflict with my previous ones.

Sorry for the burden, but I could not guess that you had stuff left unpushed after you merged, pushed to master, and marked this ticket as resolved (ce07173 is still not on master).

#13 Updated by mercedes508 about 4 years ago

  • Assignee changed from mercedes508 to sajolida
  • QA Check changed from Ready for QA to Pass

I'm fine with your changes, I reviewed your stuff, and it's great.

#14 Updated by sajolida about 4 years ago

  • Assignee deleted (sajolida)

Hmm... I obvisouly misplaced one step of the Git dance...

Fixed now as the intended version is live: https://tails.boum.org/support/known_issues/#wi-fi

Also available in: Atom PDF