Project

General

Profile

Bug #9894

Document permissions issues with i2p

Added by BitingBird almost 4 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/04/2015
Due date:
% Done:

100%

Feature Branch:
doc/9894-i2p-permissions
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
I2P

Description

The current i2p doc doesn't mention it https://tails.boum.org/doc/anonymous_internet/i2p/ and users are lost.


Related issues

Related to Tails - Bug #8280: Users should be able to manipulate local files in I2P browser Confirmed 11/20/2014
Blocks Tails - Bug #9563: FAQ: torrents with Tails -> use i2p In Progress 06/12/2015

Associated revisions

Revision 6a29e749 (diff)
Added by emma peel over 3 years ago

deleted duplicated info from known issues page, now accesible at I2P docs. Will-fix: #9894

History

#1 Updated by emmapeel almost 4 years ago

  • Related to Bug #9563: FAQ: torrents with Tails -> use i2p added

#3 Updated by emmapeel almost 4 years ago

  • Assignee set to emmapeel
  • QA Check set to Dev Needed
  • Feature Branch set to emmapeel:bugfix/9894-i2p_permissions

#4 Updated by emmapeel almost 4 years ago

  • % Done changed from 0 to 30
  • QA Check changed from Dev Needed to Ready for QA

Until #8280 is fixed, I guess, it is needed.

I copied and changed a little the phrasing from known issues page, adding steps and links.

please review

#5 Updated by emmapeel almost 4 years ago

  • Related to Bug #8280: Users should be able to manipulate local files in I2P browser added

#6 Updated by emmapeel almost 4 years ago

  • Related to deleted (Bug #9563: FAQ: torrents with Tails -> use i2p)

#7 Updated by emmapeel almost 4 years ago

  • Assignee deleted (emmapeel)

#8 Updated by BitingBird almost 4 years ago

  • Status changed from Confirmed to In Progress

#9 Updated by BitingBird almost 4 years ago

  • Target version set to Tails_1.6

#10 Updated by intrigeri almost 4 years ago

  • Assignee set to BitingBird

BitingBird, do you want to do a first pass of review before it goes to sajolida?

#11 Updated by BitingBird almost 4 years ago

  • Assignee changed from BitingBird to sajolida
  • % Done changed from 30 to 50

Looks good to me, please review another time and merge :)

#12 Updated by sajolida almost 4 years ago

  • Assignee changed from sajolida to emmapeel
  • QA Check changed from Ready for QA to Info Needed

Thanks for working on this. I understand that you copied and slightly adapted what we already have in the support/known_issues.html#index28h2. Was your idea to move all this information from the known issues into the main documentation? Because if so, they you have forgotten to remove it from the known issues. If not, then I'm not convinced by so much duplication and would rather use an inline to do have the same content displayed twice.

Also, it seems like kytv wants to solve #8280 in time for 1.6, so maybe it's not worth putting more effort and time into this doc that will hopefully be removed by then.

Once you clarified your intent and whether you think it's still worth working on this, I'll do a more detailed review.

#13 Updated by sajolida almost 4 years ago

Ah, and I also strongly suggest that you active colors in your Git to avoid trailing white spaces, see #9130#note-12.

#14 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.7

#15 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_1.7 to Tails_2.0

Postponing to a release that's in the future. Please seize this as an opportunity to check if and when you think you'll have time to work on this again :)

#16 Updated by emmapeel over 3 years ago

  • Assignee changed from emmapeel to sajolida
  • QA Check changed from Info Needed to Ready for QA

Ok, it looks like #8280 is taking a little bit more time.

I have removed the information from the Known Issues page, I think it belongs to the I2P page.

Please review topic branch

#17 Updated by sajolida over 3 years ago

  • Related to Bug #9563: FAQ: torrents with Tails -> use i2p added

#18 Updated by sajolida over 3 years ago

I'm realizing now that this is clearly related to #9563. Maybe to the point that we should solve one first and then the other. We should probably start with this one and then merge these changes into bugfix/9563-mention-i2p-for-torrents. I'll mark #9563 as blocked by this one just in case.

#19 Updated by sajolida over 3 years ago

  • Related to deleted (Bug #9563: FAQ: torrents with Tails -> use i2p)

#20 Updated by sajolida over 3 years ago

  • Blocks Bug #9563: FAQ: torrents with Tails -> use i2p added

#21 Updated by sajolida over 3 years ago

  • Priority changed from Normal to Elevated
  • Target version changed from Tails_2.0 to Tails_2.2

#22 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to emmapeel

Sorry for the delay. Here are a few comments:

  • Try to use markdown indentation instead of code (something like 4 space
    but maybe more if you're indented already).
  • Say 'start' instead of 'boot'
  • Use something to explain what your command lines do. "They need to
    belong" is maybe not clear enough. What about "Execute the following
    command to change the ownership of your files".
  • You have a placeholder in your chown commands. I suggest either
    getting rid of it with * (if that's suitable) or explain that it's a placeholder like
    we're doing in /doc/first_steps/installation/manual/linux.
  • Maybe use "`" around Unix user names?
  • I think we're usually saying "Tor Browser" (and not "the Tor
    Browser") and I see that on this page we're saying inconsistently
    "the I2P Browser" or "I2P Browser". I suggest using "I2P Browser"
    only if it works. And yeah, we're saying "the Unsafe Browser", but
    maybe that's because "unsafe" is an adjective.
  • You're missing <span class="application"> in "Exchanging files with
    the I2P Browser".

#23 Updated by emmapeel over 3 years ago

  • QA Check changed from Ready for QA to Dev Needed

#24 Updated by emmapeel over 3 years ago

sajolida wrote:

  • Say 'start' instead of 'boot'

Where exactly? in all the occurrences?

#25 Updated by emmapeel over 3 years ago

  • Assignee changed from emmapeel to sajolida
  • QA Check changed from Dev Needed to Info Needed

Ok, applied all changes except the s/start/boot. Review now, or maybe after your answer :)

#26 Updated by sajolida over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#27 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to emmapeel
  • Priority changed from Elevated to Normal
  • QA Check changed from Info Needed to Ready for QA
  • Feature Branch changed from emmapeel:bugfix/9894-i2p_permissions to doc/9894-i2p-permissions

Thanks. I did a bunch more commits with 39879c1..8fe92b3. Please have a look and tell me if we're ready for merging!

#28 Updated by anonym about 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#29 Updated by emmapeel about 3 years ago

  • Assignee deleted (emmapeel)

Looks good to me!

#30 Updated by intrigeri about 3 years ago

  • Assignee set to sajolida
  • QA Check changed from Ready for QA to Pass

#31 Updated by sajolida about 3 years ago

  • Status changed from In Progress to Duplicate
  • Assignee deleted (sajolida)
  • % Done changed from 50 to 100
  • QA Check deleted (Pass)

Merged!

Also available in: Atom PDF