Project

General

Profile

Feature #9890

Automatically test that udev-watchdog is monitoring the right device when started from USB

Added by intrigeri over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
08/04/2015
Due date:
% Done:

100%

Feature Branch:
kytv:test/9890-udev-watchdog-from-usb
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

#5560 didn't make it clear that this should be tested as well, although our manual test suite reads:

- `udev-watchdog` must monitor the right device when booted off USB (automate: [[!tails_ticket 5560]])
- `udev-watchdog` must monitor the right device when booted off DVD (automate: [[!tails_ticket 5560]])

So here's a ticket to add the missing test.


Related issues

Related to Tails - Feature #5560: Automatically test that udev-watchdog is monitoring the right device when started from DVD Resolved 01/15/2016

Associated revisions

Revision 6c2c25e0 (diff)
Added by kytv over 4 years ago

Test that udev-watchdog is monitoring the correct device when booted from USB

Will-fix: #9890

Revision f53f0a39 (diff)
Added by kytv over 4 years ago

Remove step from manual test suite; it's been automated

Will-fix: #9890

Revision 8d3d0211
Added by anonym over 4 years ago

Merge remote-tracking branch 'kytv/test/9890-udev-watchdog-from-usb' into stable

Fix-committed: #9890

History

#1 Updated by intrigeri over 4 years ago

  • Related to Feature #5560: Automatically test that udev-watchdog is monitoring the right device when started from DVD added

#3 Updated by kytv over 4 years ago

  • Status changed from Confirmed to In Progress

#5560 didn't make it clear that this should be tested as well, although our manual test suite reads:

For whatever reason I didn't think of the manual test. :S

Tucking the check into one of the existing usb_install scenarios would be cheap without extending the test suite's execution time.

Unless there are objections I'll do this for 1.5, pushed once I've tested it.

#4 Updated by intrigeri over 4 years ago

Tucking the check into one of the existing usb_install scenarios would be cheap without extending the test suite's execution time.

Sounds good to me.

#5 Updated by kytv over 4 years ago

  • Assignee changed from kytv to intrigeri
  • Target version changed from Tails_1.6 to Tails_1.5
  • QA Check set to Ready for QA
  • Feature Branch set to kytv:test/9890-udev-watchdog-from-usb

Perhaps this is acceptable.

    And process "udev-watchdog" is running                                                 # features/step_definitions/common_steps.rb:483
calling as root: ps -wweo cmd
call returned: [0, "CMD\ninit [2]                                                                                 \n[kthreadd]\n[ksoftirqd/0]\n[kworker/0:0]\n[kworker/0:0H]\n[kworker/u2:0]\n[rcu_sched]\n[rcu_bh]\n[migrati
on/0]\n[watchdog/0]\n[khelper]\n[kdevtmpfs]\n[netns]\n[khungtaskd]\n[writeback]\n[ksmd]\n[khugepaged]\n[crypto]\n[kintegrityd]\n[bioset]\n[kblockd]\n[kworker/0:1]\n[kswapd0]\n[fsnotify_mark]\n[kthrotld]\n[ipv6_addrconf]\n
[deferwq]\n[kworker/u2:1]\n[khubd]\n[ata_sff]\n[scsi_eh_0]\n[scsi_tmf_0]\n[scsi_eh_1]\n[scsi_tmf_1]\n[kworker/u2:2]\n[kworker/u2:3]\n[kworker/0:2]\n[kworker/0:1H]\n[scsi_eh_2]\n[scsi_tmf_2]\n[usb-storage]\n[loop0]\n[kwork
er/0:3]\nudevd --daemon\n[kpsmoused]\n[vballoon]\n[kworker/0:4]\n[hd-audio0]\n/usr/bin/python /usr/local/lib/tails-autotest-remote-shell /dev/ttyS0\n/usr/sbin/rsyslogd -c5\n/usr/bin/dbus-daemon --system\n/usr/sbin/cron\n/
usr/sbin/ekeyd\n/usr/sbin/cupsd -C /etc/cups/cupsd.conf\n/usr/sbin/haveged -w 1024\n/usr/sbin/memlockd -u memlockd\n/usr/sbin/pcscd\n/usr/sbin/spice-vdagentd\n/usr/sbin/console-kit-daemon --no-daemon\n/usr/lib/policykit-1
/polkitd --no-debug\n/bin/sh /usr/local/sbin/udev-watchdog-wrapper\n/usr/local/sbin/udev-watchdog /devices/pci0000:00/0000:00:05.7/usb1/1-1/1-1:1.0/host2/target2:0:0/2:0:0:0/block/sda/sda1 disk\n/usr/sbin/gdm3\n/usr/lib/g
dm3/gdm-simple-slave --display-id /org/gnome/DisplayManager/Display1\n/usr/bin/Xorg :0 -br -verbose -novtswitch -auth /var/run/gdm3/auth-for-Debian-gdm-jCGvlq/database -nolisten tcp vt8\n/usr/bin/python /usr/local/sbin/to
r-controlport-filter\n/usr/lib/accountsservice/accounts-daemon\n/usr/bin/spice-vdagent\n/usr/lib/upower/upowerd\n/usr/bin/pulseaudio --start --log-target=syslog\nstartpar -f -- tails-sdmem-on-media-removal\n/sbin/getty 38
400 tty1\n/sbin/getty 38400 tty2\n/sbin/getty 38400 tty3\n/sbin/getty 38400 tty4\n/sbin/getty 38400 tty5\n/sbin/getty 38400 tty6\ngdm-session-worker [pam/gdm3-autologin]\n[kauditd]\nperl /usr/local/sbin/tails-restricted-n
etwork-detector\nudevd --daemon\nudevd --daemon\n/usr/sbin/NetworkManager\n/usr/sbin/modem-manager\ngnome-session --session gnome-fallback\n/usr/bin/gpg-agent --daemon --sh --write-env-file=/home/amnesia/.gnupg/gpg-agent-
info-amnesia /usr/bin/dbus-launch --exit-with-session /usr/bin/monkeysphere-validation-agent x-session-manager\n/usr/bin/dbus-launch --exit-with-session /usr/bin/monkeysphere-validation-agent x-session-manager\n/usr/bin/d
bus-daemon --fork --print-pid 5 --print-address 7 --session\n/usr/bin/perl -wT /usr/bin/monkeysphere-validation-agent x-session-manager\n/usr/lib/gnome-settings-daemon/gnome-settings-daemon\n/usr/bin/spice-vdagent\n/usr/b
in/gnome-keyring-daemon --start --components=secrets\n/usr/lib/gvfs/gvfsd\n/usr/bin/pulseaudio --start --log-target=syslog\n/usr/lib/gvfs/gvfs-gdu-volume-monitor\n/usr/lib/udisks/udisks-daemon\nudisks-daemon: not polling 
any devices\n/usr/lib/gvfs/gvfs-gphoto2-volume-monitor\n/usr/lib/gvfs/gvfs-afc-volume-monitor\n/usr/bin/metacity\ngnome-panel\n/usr/lib/dconf/dconf-service\n/usr/lib/i386-linux-gnu/gconf/gconfd-2\n/usr/lib/gnome-settings-
daemon/gsd-printer\n/usr/lib/gnome-disk-utility/gdu-notification-daemon\nnm-applet\n/usr/lib/notification-daemon/notification-daemon\ngnome-sound-applet\n/usr/bin/perl /usr/local/bin/gpgApplet\n/usr/lib/policykit-1-gnome/
polkit-gnome-authentication-agent-1\n/usr/bin/python /usr/bin/system-config-printer-applet\n/bin/sh /usr/local/bin/tails-security-check-wrapper\n/bin/sh /usr/local/bin/tails-upgrade-frontend-wrapper\n/usr/lib/gnome-settin
gs-daemon/gnome-fallback-mount-helper\nnautilus -n\nflorence\npython /usr/local/lib/shutdown-helper-applet\n/usr/lib/gvfs/gvfsd-trash --spawner :1.9 /org/gtk/gvfs/exec_spaw/0\n/usr/lib/gvfs/gvfsd-burn --spawner :1.9 /org/
gtk/gvfs/exec_spaw/1\n/usr/lib/gvfs/gvfsd-metadata\n/usr/lib/at-spi2-core/at-spi-bus-launcher\n/usr/bin/dbus-daemon --config-file=/etc/at-spi2/accessibility.conf --nofork --print-address 3\nsleep 10\nsleep 10\n/bin/sh -c 
ps -wweo cmd\nps -wweo cmd\n", ""]
calling as root: cat /sys/devices/pci0000:00/0000:00:05.7/usb1/1-1/1-1:1.0/host2/target2:0:0/2:0:0:0/block/sda/sda1/dev
call returned: [0, "8:1\n", ""]
calling as root: readlink -f /dev/block/'8:1'
call returned: [0, "/dev/sda1\n", ""]
calling as root: udevadm info --device-id-of-file=/lib/live/mount/medium
call returned: [0, "8:1\n", ""]
calling as root: readlink -f /dev/block/'8:1'
call returned: [0, "/dev/sda1\n", ""]
    And udev-watchdog is monitoring the correct device  

(I'd really like to completely remove this from the manual test suite for 1.5)

#6 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

Thanks! We're theoretically frozen since 5 days, so now is way too late to add stuff to the review'n'merge queue unless it really should go into 1.5.

#7 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 50

#8 Updated by kytv over 4 years ago

#9 Updated by kytv over 4 years ago

#10 Updated by anonym over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#11 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#14 Updated by bertagaz over 4 years ago

  • Status changed from 11 to Resolved
  • QA Check deleted (Pass)

Also available in: Atom PDF