Project

General

Profile

Bug #9888

Feature #5301: Backup system for the Persistence

Feature #7049: Clone Persistence option in Tails Installer

Test deja-dup to do backups

Added by sajolida about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/03/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

deja-dup-nautilus.png View (58.2 KB) sajolida, 09/01/2015 07:48 AM

deja-dup-increments.png View (19.7 KB) sajolida, 09/01/2015 07:48 AM


Related issues

Related to Tails - Bug #10145: Investigate issues related to permissions for backup system Resolved 09/01/2015
Blocks Tails - Feature #9889: Decide a backup solution among possible candidates Rejected 08/03/2015

History

#1 Updated by sajolida about 4 years ago

  • Parent task set to #7049

#2 Updated by sajolida about 4 years ago

  • Blocks Feature #9889: Decide a backup solution among possible candidates added

#3 Updated by sajolida about 4 years ago

  • Subject changed from Consider using deja-dup to do backups to Test deja-dup to do backups
  • Status changed from Confirmed to In Progress
  • Type of work changed from Research to Test

Got a first set of remote backups and a dconf snippet to reimport my configuration each time :)

#4 Updated by intrigeri about 4 years ago

I'm curious how one can restore backups of files owned e.g. by root (such as APT stuff) with deja-dup, without ending up with dangerous ownership/permissions. We're be lucky if everything has permissions open enough to be backup'ed in the first place (not sure if it's a good idea to add this requirement to any new persistence feature so that this pre-condition holds).

Granted, these are problems shared by all backup software that run the actual backup code in the same process as the GUI, but better mention it now rather than too late :)

#5 Updated by sajolida about 4 years ago

Yes, I has these permissions issues in mind. I need to sit down and think about them in depth.

But for example, the date in the "APT stuff" has very different status than the data in "Persistent" when conceiving disastrous data loss. For example, I personally don't mind loosing everything I have in /live/persistence/TailsData_unlocked/apt/.

#6 Updated by sajolida about 4 years ago

Today I restored a file to a previous version. It took quite a while to perform, probably because of duplicity's internals and because it's remote. But the integration in Nautilus and the increments are very nice.

#7 Updated by intrigeri about 4 years ago

But for example, the date in the "APT stuff" has very different status than the data in "Persistent" when conceiving disastrous data loss.

Absolutely. Sadly, that might not be the case for all non-amnesia-owned files that users make persistent, though (either through existing presets, such as NM connections, future ones, or manually added persistent directories).

#8 Updated by intrigeri about 4 years ago

Today I restored a file to a previous version. It took quite a while to perform, probably because of duplicity's internals and because it's remote. But the integration in Nautilus and the increments are very nice.

Sounds exciting :) I wasn't aware of the integration in Nautilus, what is it doing?

#9 Updated by sajolida about 4 years ago

  • Related to Bug #10145: Investigate issues related to permissions for backup system added

#10 Updated by sajolida about 4 years ago

Regarding "amnesia" vs "root", let's move to #10145.

Regarding the desktop integration, see screenshots in attachment. You can restore files and folders to previous version by doing right-click in Nautilus.

#11 Updated by intrigeri about 4 years ago

Regarding the desktop integration, see screenshots in attachment. You can restore files and folders to previous version by doing right-click in Nautilus.

Lovely, thanks!

#12 Updated by sajolida about 4 years ago

  • Target version set to 2016

#13 Updated by sajolida almost 4 years ago

Another issues with deja-dup in Tails is about saving the dotfiles:
  • You can only add files to be backed up by Deja-Dup (and not single files)
  • If files are mounted or linked in a different place, you can only restore from Nautilus the original places backed up by Deja Dup.

So in the case of Dotfiles, it works to back up /live/persistence/TailsData_unlocked/dotfiles/ but they you can't restore them from Nautilus.

#14 Updated by intrigeri almost 4 years ago

  • You can only add files to be backed up by Deja-Dup (and not single files)

Uh?

#15 Updated by sajolida almost 4 years ago

  • You can only add files to be backed up by Deja-Dup (and not single files)

Uh?

Broken rewritten sentence, should be « You can only add folders to be
backed up by Deja-Dup (and not single files) »

#16 Updated by sajolida over 3 years ago

Another limitation, at least in Jessie, is that, when backups are triggered automatically, for example, by inserting the destination device, there is no feedback whatsoever on the progress of the backup. You only get a notification when the backup can start and when it's done, but nothing inbetween.

#17 Updated by sajolida over 3 years ago

Today I had to restore all my files from my deja-dup backups due to a broken support. The restoring went quite well; I took screenshots but forget to save them :)

The process goes like this:

  1. Install the new support.
  2. Configure persistence on the new support like it was on the old support. If you have custom persistence setting right now it's not possible to backup or restore them.
    • Fix persistence.conf if you had other custom folders. Otherwise they will get restored in $HOME before being mounted from persistence.
      1. Restart and enable persistence.
      2. Install deja-dup.
      3. Choose "Restore", point to the backup storage, and specify to restore to the "original location".
      4. Restart.

Issues:

  • Deja-Dup seems to fail to restore any symlinks. At the end of the process it displayed a long list of failed files, most of them refering to symlinks. It didn't look nice.
  • The bits of persistence that are not read-write by amnesia cannot be handled by this. See #10145. In my setup the most annoying bit was live-additional-software.conf :)

#18 Updated by sajolida over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Ok, so I'll consider that testing is done. I like deja-dup and I think it's the only candidate if we want to reuse some software with a GUI, and it's the GNOME tool (I didn't find any other that's still maintained and in Debian). But it has some shortcomings, summarized here:

  • How to deal with files not owed by amnesia? That's #10145.
  • Restoring a single file takes a while.
  • If files are mounted or linked in a different place, you can only restore from Nautilus the original places backed up by Deja Dup. That's a problem for dotfiles which are single files symlinked to $HOME and you can't easily get both the Nautilus integration and the full restoration.
  • You can only add folders to be backed up by Deja-Dup (and not single files).
  • No feedback whatsoever on the progress of the backup when they get started automatically.
  • Deja-Dup seems to fail to restore symlinks.

Also available in: Atom PDF