Project

General

Profile

Bug #9821

Feature #5663: Return to Icedove

Feature #6148: Torbirdy in Debian

Torbirdy uses Arabic as a default locale

Added by kytv over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/30/2015
Due date:
% Done:

100%

Feature Branch:
feature/5663-return-to-icedove
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

I stumbled upon this bug while experimenting with Icedove in Tails. There is a 9 month old bug filed upstream at https://trac.torproject.org/projects/tor/ticket/13721.

More details can be found on the upstream ticket but to briefly summarize the problem: in a locale which is not supported/included by Torbirdy, Torbirdy's UI will be displayed in Arabic. This is the case even when the corresponding language pack for Icedove is installed. Of the locales that Tails supports, I was able to reproduce this bug in FA, VN, and ZH.

The Torbirdy supported locales include:

ar, ca, cs, da, de, el, en, en-GB, es, eu, fr, he, hu, id, it, ko, lv, nb, nl, pa, pl, pt, pt-BR, ro, ru, sk, sl, sr, sv, tr, uk

It's probably safe to say that Arabic will be the default for any locale which is not included with Torbirdy.


Related issues

Blocked by Tails - Feature #10285: Add Icedove (and its related packages) to Tails Resolved 09/27/2015

Associated revisions

Revision f4d1f02d (diff)
Added by kytv over 4 years ago

Set en-US as the default Torbirdy locale

The XUL localization system does treat "en-US" as the hardcoded
default, but only if it is (exactly) present in the list of locales in
chrome.manifest, otherwise it'll just pick the first one, which tends to
be ar = Arabic

This commit should be reverted once
https://trac.torproject.org/projects/tor/ticket/13721 is resolved
upstream.

Will-fix: #9821

Revision c40f1b36 (diff)
Added by anonym over 4 years ago

Install xul-ext-torbirdy from Debian Testing.

We need version >= 1.4-1, which patches the locale issue in #9821. Now
we can revert the workaround we introduced in commit f4d1f02.

Will-fix: #9821

Revision 1fb5c591 (diff)
Added by anonym over 4 years ago

Revert "Set en-US as the default Torbirdy locale"

This reverts commit f4d1f02dd965a8ebdc4a68048979d1c8c3a9d626.

We now install xul-ext-torbirdy >= 1.4-1, which fixes #9821 that this
was a workaround for.

Refs: #9821

History

#1 Updated by kytv over 4 years ago

  • Parent task set to #5663

#5 Updated by u over 4 years ago

  • Assignee set to kytv
  • Target version changed from 246 to Tails_1.7
  • % Done changed from 0 to 10
  • Type of work changed from Wait to Code

i've submitted a patch and pull request https://github.com/ioerror/torbirdy/pull/24.
kytv could you add that to the tpo bug please?
kytv fixes it as a delta in the meantime. assigning the ticket to him.

#6 Updated by kytv over 4 years ago

u wrote:

i've submitted a patch and pull request https://github.com/ioerror/torbirdy/pull/24.
kytv could you add that to the tpo bug please?
kytv fixes it as a delta in the meantime. assigning the ticket to him.

I updated the upstream ticket to advise them of u 's pull request.

#7 Updated by kytv over 4 years ago

  • Blocked by Feature #10285: Add Icedove (and its related packages) to Tails added

#8 Updated by kytv over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 10 to 40
  • Feature Branch set to kytv:bugfix/9821-torbirdy-arabic

In the event that upstream takes a while to fix this bug, the branch in this ticket will resolve this bug for Tails, allowing Icedove w/ torbirdy to enter Tails at version 1.7.

Maybe we'll luck out and this branch can be forgotten about.

#10 Updated by kytv over 4 years ago

  • Assignee changed from kytv to anonym
  • QA Check set to Ready for QA

u wrote:

our patch has been merged upstream: https://github.com/ioerror/torbirdy/commit/19cc1c71b9ee44554f3ff5ac6006da1380bd3a95

Excellent! Now we just need a new release with the fix or the Debian packages to include it, then the branch in this ticket can be discarded.

#12 Updated by u over 4 years ago

kytv wrote:

u wrote:

our patch has been merged upstream: https://github.com/ioerror/torbirdy/commit/19cc1c71b9ee44554f3ff5ac6006da1380bd3a95

Excellent! Now we just need a new release with the fix or the Debian packages to include it, then the branch in this ticket can be discarded.

I've prepared the Debian package but I need to review the branch layout before it can be uploaded: https://lists.alioth.debian.org/pipermail/pkg-privacy-maintainers/Week-of-Mon-20150928/000038.html

#13 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Dev Needed

#14 Updated by kytv over 4 years ago

  • QA Check changed from Dev Needed to Ready for QA

#15 Updated by kytv over 4 years ago

  • Assignee changed from kytv to anonym

#16 Updated by kytv over 4 years ago

#17 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Pass

I've tested your local fix. However, let's wait and see if we get a fixed Debian package first. Will you take care of that, kytv, since you're already deep in the loop?

#18 Updated by u over 4 years ago

I've updated the package but need a sponsor to upload it, once the branch layout is fixed (doing that atm).

#19 Updated by u over 4 years ago

fyi thanks to intrigeri the updated package has now landed in Debian unstable.

#20 Updated by anonym over 4 years ago

#21 Updated by anonym over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100

#22 Updated by anonym over 4 years ago

  • Assignee deleted (kytv)
  • Feature Branch changed from kytv:bugfix/9821-torbirdy-arabic to feature/5663-return-to-icedove

Also available in: Atom PDF