Project

General

Profile

Feature #9811

Remove Nyx (arm)

Added by sajolida about 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Tor configuration
Target version:
Start date:
07/29/2015
Due date:
% Done:

100%

Feature Branch:
spriver:feature/9811-remove-arm
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

We are shipping the tor-arm package but it is not mentionned anywhere in our documentation (thus #8915). But do we really need it? Could we remove it?


Related issues

Related to Tails - Feature #8915: Document Nyx (arm) Resolved 02/18/2015
Related to Tails - Feature #8927: Replicate Vidalia's ability to close arbitrary circuits Confirmed 02/21/2015

Associated revisions

Revision d49f99b5
Added by anonym almost 3 years ago

Merge remote-tracking branch 'spriver/feature/9811-remove-arm' into devel

Fix-committed: #9811

History

#1 Updated by sajolida about 4 years ago

#2 Updated by sajolida about 4 years ago

  • Related to Feature #8927: Replicate Vidalia's ability to close arbitrary circuits added

#3 Updated by intrigeri about 4 years ago

  • Type of work changed from Code to Research

Next step seems to be to check how well this would play with our plan for removing Vidalia (IIRC we meant to rely on arm for replacing some of the "advanced" features Vidalia currently provides, but I may be misremembering), sum it up, and then raise this topic at the monthly meeting or on -dev@.

#4 Updated by sajolida about 4 years ago

  • Target version deleted (Tails_1.5)

Let's do this while working on Tor Monitor then, and not before.

#5 Updated by intrigeri about 4 years ago

  • Subject changed from Remove arm to Remove Nyx (arm)

#6 Updated by sajolida over 3 years ago

Right now, executing arm in a terminal leads to this:

amnesia@amnesia:~$ arm
Connection refused. Is the ControlPort enabled?

Is is broken or is some magic incantation needed to make it work?

#7 Updated by spriver over 3 years ago

sajolida wrote:

Right now, executing arm in a terminal leads to this:

[...]

Is is broken or is some magic incantation needed to make it work?

Apparently root privileges are needed for running arm (which is not recommended). Was it possible to run arm without sudo previously?

#8 Updated by intrigeri over 3 years ago

Was it possible to run arm without sudo previously?

I don't think so.

(Actually, iirc running as the debian-tor user should work, and be safer.)

#9 Updated by spriver over 3 years ago

intrigeri wrote:

Was it possible to run arm without sudo previously?

I don't think so.

(Actually, iirc running as the debian-tor user should work, and be safer.)

sudo -u debian-tor arm works indeed but needs an administration password then.
I don't know if arm/nyx is needed at all. I never needed it in Tails since it's more a relay configuration tool and several (technically not skilled) users I spoke to did not even knew what arm is or never wanted to use it. IMHO arm is advanced software and if user's need it they are more skilled in terms of Linux and will install it manually then.

#10 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#11 Updated by intrigeri over 3 years ago

Type of code: Code

IMHO arm is advanced software and if user's need it they are more skilled in terms of Linux and will install it manually then.

Yes. I say remove it.

(I was the one who thought some facts checking was needed a year ago, so I feel comfortable moving it to "Code", given three of us agree it should go away.)

#12 Updated by spriver about 3 years ago

Since we agreed on removal; shall we create a ticket concerning the removal of arm or modify this one to do so?

#13 Updated by intrigeri about 3 years ago

  • Type of work changed from Research to Code

#14 Updated by spriver about 3 years ago

  • Assignee set to spriver

#15 Updated by spriver about 3 years ago

  • Target version set to Tails_2.9.1

#16 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#17 Updated by spriver almost 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from spriver to anonym
  • QA Check set to Ready for QA
  • Feature Branch set to spriver:feature/9811-remove-arm

Done this task. I did not knew if I had to change debian/changelog too, so I did this. If not, please cherry-pick the commit only removing tor-arm.

#18 Updated by spriver almost 3 years ago

spriver wrote:

Done this task. I did not knew if I had to change debian/changelog too, so I did this. If not, please cherry-pick the commit only removing tor-arm.

edit: as intrigeri told me the release notes are built during the release process. Reverted the superfluous commit, HEAD is now at 051e48f Removed nyx/arm

#19 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

Merged, thanks!

#20 Updated by anonym almost 3 years ago

  • % Done changed from 0 to 100

#21 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF