Project

General

Profile

Bug #9810

Bluetooth options in System settings has no icon

Added by emmapeel over 4 years ago. Updated over 2 years ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
07/28/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Reported in irc, confirmed by me:

Steps to reproduce:

- Open Applications/System Tools/Preferences/System settings.

The Bluetooth option has no icon. See screenshot.

bluetoothicomissing.png View (51.6 KB) emmapeel, 07/28/2015 09:03 AM

bluetooth-menu.png View (10.3 KB) emmapeel, 08/03/2015 05:15 AM

bluetooth.png View - bluetooth icon (4.48 KB) emmapeel, 08/05/2015 10:53 AM


Related issues

Related to Tails - Bug #11545: Make "Online Accounts" work in Tails or hide them Resolved 06/24/2016
Duplicated by Tails - Bug #7520: No Bluetooth icon the system settings window Duplicate 07/09/2014

History

#1 Updated by emmapeel over 4 years ago

  • File deleted (gnome-control-center.desktop)

#2 Updated by BitingBird over 4 years ago

  • QA Check deleted (Dev Needed)

#3 Updated by emmapeel over 4 years ago

Also in Jessie:

I can see this problem also with tails-i386-feature_jessie-1.5-20150731T0408Z-9946a87.iso

#4 Updated by intrigeri over 4 years ago

  • Assignee set to emmapeel
  • Priority changed from Normal to Low
  • QA Check set to Info Needed

Last time I've checked, we did not ship a Bluetooth userspace stack, so IMO that's low priority.

What happens when one clicks that icon, by the way? (my virtualization setup is broken right now, otherwise I would have checked myself)

#5 Updated by emmapeel over 4 years ago

intrigeri wrote:

Last time I've checked, we did not ship a Bluetooth userspace stack, so IMO that's low priority.

Definitely a low priority ticket...

What happens when one clicks that icon, by the way? (my virtualization setup is broken right now, otherwise I would have checked myself)

The resulting menu in Taills 1.4.1 is very boring, see screenshot:

Will test in Jessie later.

#6 Updated by emmapeel over 4 years ago

  • Assignee deleted (emmapeel)
  • Type of work changed from Code to Discuss

In Jessie there is a different menu, but as autistic as the one I posted previously.
If I were to code it, I would say we should replace this with some message documenting why we don't ship the Bluetooth stack etc (or with a link to the documentation page about it).

But it is just a detail really...

#7 Updated by intrigeri over 4 years ago

  • Type of work changed from Discuss to Code

OK, so that's a low-priority code ticket (I don't see what's left to discuss here).

My preferred implementation option would be to ship the missing icon in our source tree (because most likely we don't want to install the package that ships it). That should be easy.

#8 Updated by emmapeel over 4 years ago

  • Duplicated by Bug #7520: No Bluetooth icon the system settings window added

#9 Updated by emmapeel over 4 years ago

There is a very nice icon shipped already, at

/usr/share/icons/Windows8/apps/bluetooth.png

bluetooth icon

#10 Updated by BitingBird over 4 years ago

  • QA Check deleted (Info Needed)

#11 Updated by BitingBird over 3 years ago

Maybe it would be even better to remove the entry from the menu?

#12 Updated by sajolida over 3 years ago

  • Related to Bug #11545: Make "Online Accounts" work in Tails or hide them added

#13 Updated by sajolida over 3 years ago

Hiding this entry would be similar that what I'm proposing for #11545.

#14 Updated by u over 2 years ago

I suppose that it's because the icon is in some software that we don't ship that it does not show up. Still the case in Tails 3.0 and still very low prio.

#15 Updated by u over 2 years ago

  • Starter deleted (Yes)

Also available in: Atom PDF