Project

General

Profile

Bug #9792

Syncing keys in Seahorse does not work in Jessie

Added by kytv over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
07/22/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Until the test suite scenario is updated this can be verified with the following:

1. `gpg --recv-key --keyserver-options import-clean 0x1D84CCF010CC5BC7`
2. Open Seahorse
3. Enable key synchronization in Edit → Preferences
4. Sync keys from Remote → Sync and Publish Keys
5. Click the Sync button
6. Check the number of signatures with `gpg --list-sigs 0x1D84CCF010CC5BC7`. You should have more than 3 signatures.

This works in Wheezy. It does not in Jessie.


Related issues

Blocks Tails - Bug #9791: Update torified_gnupg feature for Jessie Resolved 07/22/2015 01/15/2016

Associated revisions

Revision 7a536e69 (diff)
Added by intrigeri about 4 years ago

Also wrap Seahorse with torsocks when it is started as a D-Bus service.

It's started this way e.g. with "Password and keys" from the Activities Overview
and applications menu.

Closes: #9792

History

#1 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri
  • Target version changed from Tails_1.8 to Tails_2.0

That's because our wrapping of seahorse by torsocks, in seahorse.desktop, is apparently not enough: I see direct connections to the keyserver being blocked by the firewall. I tried wrapping seahorse-pgp-keys.desktop the same way, and it is not enough / doesn't help.

OTOH, running torsocks seahorse in a Terminal gives me a seahorse that can fetch keys perfectly fine.

#2 Updated by intrigeri over 4 years ago

  • Blocks Bug #9791: Update torified_gnupg feature for Jessie added

#3 Updated by intrigeri over 4 years ago

  • Priority changed from Normal to High

(Blocks a high prio ticket.)

#6 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_2.0 to Tails_1.8

#7 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#8 Updated by intrigeri about 4 years ago

  • Assignee deleted (intrigeri)
  • Target version changed from Tails_1.8 to Tails_2.0

Also available in: Atom PDF