Project

General

Profile

Bug #9710

nautilus-wipe cannot handle dynamic Desktop links

Added by DanOver over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
07/08/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

If the user clicks in "Wipe" on the menu of the trash, Tails clean all items on desktop and the items on the trash aren't changed.

History

#1 Updated by intrigeri over 4 years ago

  • Assignee set to emmapeel
  • QA Check set to Info Needed

Oops, that sounds like a nasty bug in nautilus-wipe.

Please reproduce or reassign to current frontdesk, and then we'll report this bug to the relevant upstream authors (bonus points if you do it yourself :)

#2 Updated by kytv over 4 years ago

FWIW I can confirm this. It's true for right clicking on Trash, home, or Computer and picking Wipe from the context menu. It will not do it for a user created file or folder and it will not do it for Report an Error or Tails documentation.

You'll see a prompt of Are you sure you want to wipe "Desktop"? If you click the Wipe button it'll go through with it.

I cannot confirm this when /not/ using the context menu on the desktop. Clicking Wipe from the context menu within Nautilus on a folder within /home/amnesia, for example, works as expected.

#3 Updated by BitingBird over 4 years ago

  • Status changed from New to Confirmed

#4 Updated by emmapeel over 4 years ago

  • Assignee changed from emmapeel to intrigeri

I cannot reproduce on Debian Jessie, as right-clicking on the menu doesn't give me any 'Wipe' option (it may be because of my window manager...)

Although I can confirm this bug is happening in my Tails 1.4.1 install.

Shall I report this to debian, to nautilus-wipe debian upstream, or we need to look onto some magic Wipe options for nautilus-wipe that we added in Tails?

#5 Updated by emmapeel over 4 years ago

  • Subject changed from Wipe Trash to nautilus-wipe cannot handle dynamic Desktop links
  • Assignee changed from intrigeri to emmapeel

Ok. It is a nautilus-wipe missing feature.

I think I can narrow the error down to wiping links generated by the window manager on the desktop, not real files.

If I go in the shell to /home/amnesia/Desktop I just see two files:

amnesia@amnesia:~$ ls Desktop/
Report_an_error.desktop tails-documentation.desktop

This files are not problematic, the problem is the Computer, Home and Trash icons on the Desktop.

#6 Updated by alant almost 3 years ago

  • Status changed from Confirmed to In Progress
  • Target version set to Tails_3.0
  • QA Check deleted (Info Needed)

This is fixed in nautilus-wipe 0.3, which is in debian stretch:

Fix resolving path to virtual (desktop shortcut) locations

Do not consider every URI with an x-nautilus-desktop scheme as pointing
directly to the desktop, as "Computer", "Trash" and other virtual
shortcuts share this scheme on the desktop.

This fixes handling of all virtual shortcuts pointing to simple local
locations, like drives and home directory. It doesn't handle trash
yet, because it's a lot less straightforward and Nautilus doesn't help
much on that.

Fixes https://labs.riseup.net/code/issues/9710

https://git.tuxfamily.org/wipetools/nautiluswipe.git/commit/?id=d7b46ce43ad5e7fca9d4f9ff14e85383340d123d

#7 Updated by intrigeri almost 3 years ago

  • Status changed from In Progress to Resolved

This is fixed in nautilus-wipe 0.3, which is in debian stretch:

Closing, then.

Also available in: Atom PDF