Project

General

Profile

Bug #9692

Feature #7563: Update the automated test suite for Jessie ISO images

Test suite's --retry-find option breaks wait_for_gnome_window

Added by intrigeri about 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
-
Start date:
07/05/2015
Due date:
01/15/2016
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

It seems that the specified timeout is not respected, and just a few seconds after sikuli started waiting for the picture, it fails and asks for the image to be updated. I've seen that in:

@screen.wait_for_gnome_window('PersistenceWizardWindow.png', 40)

History

#1 Updated by intrigeri about 4 years ago

  • Priority changed from Normal to High
  • Target version changed from Tails_2.0 to Tails_1.8
  • Parent task set to #7563

(Copying metadata from the parent ticket.)

#2 Updated by intrigeri about 4 years ago

  • Due date set to 01/15/2016

#5 Updated by anonym about 4 years ago

Honestly, when I added --retry-find it was supposed to be a cheap fix for solving 90% of the problem (i.e. something that makes updating the images easier). Fixing the last 10% would take probably 10x the initial implementation effort, and make the Sikuli monkey-patching we do crazy. Here the issue is that we implement our own waiting mechanism with a looped (via try_for) find() (so we have the same issue for at least waitAny() as well). One way to fix this would be to temporarily disable the findfailed_hook for find()... some how. This will become incredibly ugly.

I'm not sure I want to fix this.

#6 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to Rejected

I'm not sure I want to fix this.

Agreed, the "solutions" seem to be worse than the problem.

#7 Updated by intrigeri about 4 years ago

  • Assignee deleted (anonym)
  • Target version deleted (Tails_1.8)

#9 Updated by intrigeri almost 4 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF