Project

General

Profile

Feature #9683

Feature #6196: Build all active branches

Feature #6090: Automated builds

Bug #9682: Upstream our changes in puppet-jenkins

Check if we still need to patch the Jenkins puppet service definition

Added by bertagaz almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
07/04/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
puppet-jenkins:features/9618-stronger_plugin_verification
Type of work:
Sysadmin
Blueprint:
Starter:
No
Affected tool:

Description

We patched the upstream puppet-jenkins module to have a better service definition working with Debian's Jenkins daemon.

That's feature/better_service_definition branch of the Tails puppet-jenkins module clone.

But our puppet-module is lagging a lot behind the upstream.

We need to first upgrade this module and check if this change is still relevant. If it is, then we'll have to upstream it.


Related issues

Duplicated by Tails - Feature #9618: Check if we still need to patch the Jenkins puppet service definition Duplicate 06/19/2015

History

#1 Updated by bertagaz almost 4 years ago

  • Parent task set to #9682

#3 Updated by bertagaz almost 4 years ago

This ticket is a duplicate of the buggy #9618, means to replace it.

#4 Updated by intrigeri almost 4 years ago

This ticket is a duplicate of the buggy #9618, means to replace it.

OK, but #9618 is still open, and marked as blocking #9682, so it's getting a bit confusing.

#5 Updated by bertagaz almost 4 years ago

intrigeri wrote:

This ticket is a duplicate of the buggy #9618, means to replace it.

OK, but #9618 is still open, and marked as blocking #9682, so it's getting a bit confusing.

Yes, but I actually can't close it (the status are limited), and its notes contains informations. I'm a bit afraid of losing it if I manipulate it, so I prefer to wait for this new ticket to be closed to take care of #9618.

#6 Updated by intrigeri almost 4 years ago

OK, but #9618 is still open, and marked as blocking #9682, so it's getting a bit confusing.

Yes, but I actually can't close it (the status are limited),

I bet you can't close it because it's blocked by #9619.

#7 Updated by bertagaz almost 4 years ago

But I can't close #9619 (really), gives me "Invalid parent" when I try, and I can't change its parent, gives me a 404...

#8 Updated by bertagaz almost 4 years ago

  • % Done changed from 0 to 90
  • QA Check changed from Info Needed to Ready for QA

So, I've updated the jenkins module to last upstream tag + our stronger_plugin_verification branch, and the service seems to be managed correctly by default by the upstream manifests. I've just dropped that patch from our module.

I don't think we need to upstream this old change anymore. Delta--, yay!

#9 Updated by intrigeri almost 4 years ago

But I can't close #9619 (really), gives me "Invalid parent" when I try, and I can't change its parent, gives me a 404...

Indeed, its parent_id was set to 6956, which I mistakenly deleted (still don't know how, but well). I've fixed that in the database, and could then close #9619 and #9618 :) Sorry for creating this mess...

#10 Updated by intrigeri almost 4 years ago

  • Duplicated by Feature #9618: Check if we still need to patch the Jenkins puppet service definition added

#11 Updated by intrigeri almost 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
  • QA Check changed from Ready for QA to Pass

So, I've updated the jenkins module to last upstream tag + our stronger_plugin_verification branch, and the service seems to be managed correctly by default by the upstream manifests.

Confirmed:

  • by manually stopping the service: Puppet correctly restarts it
  • Puppet doesn't restart the service if already running.

Yay :)

#12 Updated by intrigeri almost 4 years ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF