Project

General

Profile

Bug #9671

rss and atom feed of l10n news show po file source

Added by muri about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
07/03/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/9671-no-inline-for-release-notes
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

when accessing a localized version of the rss or atom feed, the content of the entries shows the source of the po files:
https://tails.boum.org/news/index.de.atom
https://tails.boum.org/news/index.de.rss


Related issues

Related to Tails - Bug #10124: po_translatable_pages is unstable on boum.org Rejected 08/31/2015
Related to Tails - Bug #6907: ikiwiki po plugin does not play well with inline directives Resolved 12/03/2018 03/12/2019
Related to Tails - Bug #11135: Disable translations of /news/reports Resolved 02/17/2016

Associated revisions

Revision 3e971dcf (diff)
Added by intrigeri almost 4 years ago

Move release notes back to the corresponding release announce page.

... and:

  • salvage existing translations (only relevant for 1.7)

Will-fix: #9671

Revision e7d5fe94 (diff)
Added by intrigeri almost 4 years ago

ikiwiki*.setup: forget about inc/release_notes.

It was a great idea. But implementing it was not a great idea in the end,
given ikiwiki's shortcoming (#6907).

Refs: #9671

Revision 9f58d476 (diff)
Added by intrigeri almost 4 years ago

Release process: remove now obsolete bits about release notes as inlined snippets.

Will-fix: #9671

Revision 2b8d3bd5
Added by intrigeri over 3 years ago

Merge branch 'bugfix/9671-no-inline-for-release-notes'

Closes: #9671

History

#1 Updated by mercedes508 about 4 years ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri about 4 years ago

I just spent quite some time trying to fix that locally. I tried many combinations of:

  • removing raw="yes" from the inline directives we've recently added on wiki/src/news/version_1.4.1.mdwn, wiki/src/news/version_1.4.mdwn and wiki/src/news/report_2015_05.mdwn
  • "translating" every such inline directive into German:
    • pointing it to the English page name (e.g. [[!inline pages="inc/release_notes/1.4" raw="yes"]])
    • pointing it to the German page name (e.g. [[!inline pages="inc/release_notes/1.4.de" raw="yes"]])

None of those worked.

However, removing these three inline directives fixed the problem for me. So, it looks like this chain of inline (the one on news.mdwn that generates the feeds, that pulls the ones from these 3 pages in news/, that themselves pull content from wiki/src/inc/release_notes/) is buggy with current ikiwiki. I can't say I'm very surprised: inline + po plugin have been fragile historically, and here we're pushing the limits a bit too far, maybe.

So, either someone fixes the bug in ikiwiki, or someone finds a workaround, or we'll have to remove these new inline directives, and deal with the duplication of content between release notes and monthly reports in another way.

#3 Updated by intrigeri about 4 years ago

  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.5

(That's a regression.)

#4 Updated by intrigeri about 4 years ago

  • Assignee set to anonym
  • Target version changed from Tails_1.5 to Tails_1.6

Let's see this as part of the RM's regression fixing duty. At the monthly meeting we agreed on reverting the fancy inlining of stuff, and instead linking to release notes.

#5 Updated by anonym about 4 years ago

intrigeri wrote:

So, either someone fixes the bug in ikiwiki

My perl sucks too much for even considering trying...

or someone finds a workaround

... and my knowledge of ikiwiki is pretty shallow. I couldn't even had come up with the fixes you tried.

or we'll have to remove these new inline directives, and deal with the duplication of content between release notes and monthly reports in another way.

So this is the only thing what I could do, without much of a solution for how to deal with the translations in a sweet way. How much of a problem would that be? It doesn't look like our reports get translated much, and frankly the reports seems mostly targeted at people interested in Tails development, which require knowing English any way. Isn't copy-pasting the release notes an acceptable "solution"? Or just skipping that part, and just linking to any actual release's page.

Unfortunately, I feel like a poor match for actually solving the problem. :/

#6 Updated by anonym about 4 years ago

  • Assignee changed from anonym to BitingBird
  • QA Check set to Info Needed

What's your take on this, since you're the one mostly working on these reports?

#7 Updated by intrigeri about 4 years ago

Isn't copy-pasting the release notes an acceptable "solution"? Or just skipping that part, and just linking to any actual release's page.

I think we need to remove all inlines introduced by e.g. https://mailman.boum.org/pipermail/tails-project/2015-June/000227.html, and same in all following monthly reports. There was an argument in this thread in favour of not merely linking, and at DebConf I've talked with at least one person who's reading our monthly reports and is happy to have the release notes in them, so my preferred "solution" currently is simply copy'n'pasting release notes into reports, and too bad if they won't be translated in the monthly reports.

#8 Updated by BitingBird about 4 years ago

  • Assignee changed from BitingBird to anonym
  • Target version changed from Tails_1.6 to Tails_1.7

I don't want to deal with inlines, so what intri says :)

#9 Updated by intrigeri almost 4 years ago

  • Related to Bug #10124: po_translatable_pages is unstable on boum.org added

#10 Updated by intrigeri almost 4 years ago

  • Related to Bug #6907: ikiwiki po plugin does not play well with inline directives added

#11 Updated by intrigeri almost 4 years ago

  • QA Check deleted (Info Needed)

The likely root cause is tracked at #6907, so let's focus on reverting stuff to the previously working state here.

#12 Updated by anonym almost 4 years ago

  • Target version changed from Tails_1.7 to Tails_1.8

#13 Updated by intrigeri almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri

#14 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/9671-no-inline-for-release-notes

sajolida, can you please review this and merge into master if you like it?

(You'll want to temporarily enable feed generation in ikiwiki.setup in order to test it; anonym doesn't know these things much, which I bet explains why he didn't work on it in the past few months, so better have someone better skilled at ikiwiki craziness review my branch :)

I'm told that some people would like to resume work on monthly reports, and since we had inlines no such report was completed, which might not be a mere coincidence... hence my motivation today to fix this situation! Sorry I didn't revert this mess earlier..

#15 Updated by sajolida almost 4 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

#16 Updated by intrigeri almost 4 years ago

Now that 1.8 and 1.8.1 have been released, more work is needed since these two release processes have followed the unpatched release doc. Do you want to do the forward-porting yourself? I can do it once now, if I'm confident the result will be merged before the 2.0 release process and thus I don't have to do it again in the future.

#17 Updated by intrigeri over 3 years ago

intrigeri wrote:

Now that 1.8 and 1.8.1 have been released, more work is needed since these two release processes have followed the unpatched release doc.

Add 1.8.2 to this list.

Do you want to do the forward-porting yourself? I can do it once now, if I'm confident the result will be merged before the 2.0 release process and thus I don't have to do it again in the future.

Ping? The more we wait, the more boring, useless forward-porting work will be needed.

You can also tell me that I should not block on you for this one any longer, and then I'll do the forward-porting and merge myself, and then you'll give it a look when you have more time :)

#18 Updated by sajolida over 3 years ago

  • Priority changed from Elevated to High
  • Target version changed from Tails_2.0 to Tails_2.2

#19 Updated by sajolida over 3 years ago

  • Related to Bug #11135: Disable translations of /news/reports added

#20 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to intrigeri

Sorry for taking so long on this one. It's the kind of TODO that I've seen for ages in my agenda view but in the end even forget what it was about. I checked you're work, it's fine and I'm excited we get rid of this. I updated your branch for 1.8.1 and later. Please review again.

Then maybe we should synchronize with #11135 to ask to update their ikiwiki.setup only once. I'll work on #11135 right now.

#21 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Merged, pushing.

#22 Updated by sajolida over 3 years ago

I'm not sure why but this is not the case anymore...

Also available in: Atom PDF