Project

General

Profile

Feature #9601

Feature #6196: Build all active branches

Add a merge step to our Jenkins ISO build process

Added by bertagaz over 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Elevated
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
06/17/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

In our automatic builds specs, we designed that we wanted the build of feature branches to be done after it has been merged locally in their base branch.

We still need to implement this, as at the moment we only build from the feature branch.

This will probably mean modifying our vagrant/provision/assets/build-tails script.

History

#1 Updated by bertagaz over 4 years ago

  • Parent task set to #6196

#2 Updated by bertagaz over 4 years ago

  • Priority changed from Normal to Elevated

#3 Updated by bertagaz over 4 years ago

  • Assignee changed from bertagaz to intrigeri

We'll probably need to use some of the auto/scripts/tails-custom-apt-sources functions in the vagrant/provision/assets/build-tails script, namely base_branch and friends.

To avoid code duplication we should put this functions in a separate shell lib.

I guess the best place is in the lib/ folder of the Tails repo, where the pythonlib already lay.

We should create a lib/shell folder in the Tails git repo, but is it required to create a dedicated submodule as the pythonlib? Or should we wait until it grows?

#4 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check set to Info Needed

I'm confused: it seems that what you're asking for was done a few months ago, see e.g. b0fbe52. What's missing exactly?

#5 Updated by bertagaz over 4 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (bertagaz)

Awesome! I haven't seen it because I only thought to have a look to the build-tails script, and not the auto/build one.

So nothing is missing, closing this ticket then, thx.

Also available in: Atom PDF