Project

General

Profile

Bug #9564

translated file doesn't get parsed in ikiwiki

Added by muri over 4 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
06/12/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

in wiki/src/doc/first_steps/upgrade.mdwn the line

[[!inline pages="doc/first_steps/upgrade.release_notes" raw="yes"]]

occurs two times. when translating the file, we translate this line to
[[!inline pages="doc/first_steps/upgrade.release_notes.de" raw="yes"]]

this leads to the translated release notes to be included as expected at the first occurance of this inline statement, but at the second occurrance, it is being included but not parsed.
i've attached a screenshot and the commits to reproduce the behaviour are in https://gitlab.com/muri/tails.git, branch bug-ikiwiki-po

Screenshot from 2015-06-12 11_38_07.png View (116 KB) muri, 06/12/2015 09:39 AM

fixed.png View (17.2 KB) sajolida, 08/18/2015 09:59 AM

Screenshot from 2015-08-28 12_12_05.png View (109 KB) emmapeel, 08/28/2015 05:27 AM


Related issues

Duplicates Tails - Bug #6907: ikiwiki po plugin does not play well with inline directives Resolved 12/03/2018 03/12/2019

History

#1 Updated by sajolida over 4 years ago

  • Status changed from New to Confirmed
  • Assignee set to sajolida

I'll have a look "at some point".

Until then, if you want to try to fix that yourself I would start by converting doc/first_steps/upgrade.release_notes and the rest of the content of the <div> to pure HTML. In ikiwiki, once you open an HTML tag (here <div>) you should write pure HTML inside (ikiwiki can't guess when you're going back to markdown). This means adding <p> for each paragraph, etc.

#2 Updated by sajolida over 4 years ago

  • File fixed.png View added
  • Assignee changed from sajolida to muri
  • QA Check changed from Dev Needed to Ready for QA

I finally had a look and I could fix this locally. See the screenshot in attachment. To do so maybe commit 44486bc help. I pushed it to master.

But most of all, I had to fix my ikiwiki.setup to include "inc/stable_i386_release_notes" in the list of translatable pages. So if this happened to you locally only, make sure to synchronize with the po_translatable_pages with ikiwiki.setup.

If that works for you, then please close this ticket.

#3 Updated by emmapeel over 4 years ago

I have seen this today in the Download page, see screenshot:

!Screenshot from 2015-08-28 12:12:05.png!

#4 Updated by sajolida over 4 years ago

All the times I've seen this happened it was caused by buggy po_translatable_pages in ikiwiki.setup. So I'm reopening #9279 instead.

#5 Updated by muri over 4 years ago

  • Status changed from Confirmed to Duplicate

hi,

i tested again and at the moment locally the inline statement mentioned in the bug report doesn't get translated at all. but as far as i can see, there are now multiple other tickets about this po-bug, so i'm closing as duplicate (hope thats the right way to handle this one)

#6 Updated by intrigeri over 4 years ago

but as far as i can see, there are now multiple other tickets about this po-bug, so i'm closing as duplicate (hope thats the right way to handle this one)

Indeed, there's more details on #9671, #9279 and #10124, so that should be enough tickets about this bug for now.

#7 Updated by intrigeri over 4 years ago

  • Duplicates Bug #6907: ikiwiki po plugin does not play well with inline directives added

#8 Updated by intrigeri about 1 year ago

  • QA Check deleted (Ready for QA)

Also available in: Atom PDF