Project

General

Profile

Bug #9560

Upgrade Tor to 0.2.6.9

Added by intrigeri over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
06/11/2015
Due date:
% Done:

100%

Feature Branch:
feature/9560-tor-0.2.6.9
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

We should do this in general, but even more so this time since it has one bugfix that we particularly want: "Properly separate out each SOCKSPort when applying stream isolation".

Associated revisions

Revision 1710694d
Added by intrigeri about 4 years ago

Merge branch 'feature/9560-tor-0.2.6.9' into stable

Fix-committed: #9560

History

#1 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to feature/9560-tor-0.2.6.9

Package built, packaging instructions updated. Next step: test it.

#2 Updated by intrigeri about 4 years ago

Oh crap, I forgot to apply bug15482.patch since the release doc was not updated accordingly back when we decided to take that patch :/ Updating package again, will ask for a review'n'merge later today.

#3 Updated by intrigeri about 4 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Passes features/apt.feature features/tor*.feature features/time_syncing.feature.

#4 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#5 Updated by BitingBird about 4 years ago

  • QA Check changed from Ready for QA to Pass

#6 Updated by BitingBird about 4 years ago

  • QA Check changed from Pass to Ready for QA

#7 Updated by intrigeri about 4 years ago

  • Status changed from Fix committed to Resolved

#8 Updated by intrigeri about 4 years ago

  • QA Check changed from Ready for QA to Pass

(This was reviewed as part of the 1.4...1.4.1 diff during the 1.4.1's manual test suite.)

Also available in: Atom PDF