Project

General

Profile

Feature #9515

Improve test suite robustness vs transient network errors

Added by anonym about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
Start date:
06/02/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The amount of false positives we get from tests failing due to transient network errors (e.g. Tor being slow, Exit node blocking, the live destination servers having issues etc.) is already problematic, and is blocking deployment in our Jenkins infrastructure (#8539). Let's make the tests must susceptible to these issues simulate a user retrying (in a suitable manner) whenever such errors occur.


Subtasks

Feature #9516: Restart Tor if bootstrapping stalls for too longResolved

Feature #9517: Retry connecting to OFTC when it failsResolved

Feature #9518: Retry with new OpenPGP key server pool member when they misbehaveResolved

Feature #9668: Retry whois request on "WHOIS LIMIT EXCEEDED"Resolved

Bug #6092: Tails Installer sometimes hangs late in the installation processResolved

Bug #9715: Retry wget in the test suite when failing to resolve a hostResolved


Related issues

Related to Tails - Bug #9478: How to deal with transient network errors in the test suite? Resolved 05/27/2015

History

#1 Updated by anonym about 4 years ago

  • Related to Bug #9478: How to deal with transient network errors in the test suite? added

#2 Updated by anonym about 4 years ago

  • Blocks Feature #8539: Make the test suite robust enough to be run as part of a CI setup added

#3 Updated by anonym about 4 years ago

I couldn't make this ticket a child of #8539, adding it as a blocker then.

#4 Updated by anonym about 4 years ago

  • Assignee set to kytv
  • Target version set to Tails_1.4.1

Please change the milestone if 1.4.1 is too optimistic.

#6 Updated by intrigeri about 4 years ago

Maybe this should be a subticket of #8539, instead of a ticket that blocks it? If you don't mind, I'll just do it.

#7 Updated by intrigeri about 4 years ago

  • Related to deleted (Bug #9478: How to deal with transient network errors in the test suite?)

#8 Updated by intrigeri about 4 years ago

  • Blocks deleted (Feature #8539: Make the test suite robust enough to be run as part of a CI setup)

#10 Updated by intrigeri about 4 years ago

  • Parent task set to #8539

#11 Updated by intrigeri about 4 years ago

  • Related to Bug #9478: How to deal with transient network errors in the test suite? added

#13 Updated by intrigeri about 4 years ago

Sorry for the noise, I missed the fact that you had unsuccessfully tried to do it. Now done. I had to delete all ticket relationships for this one and each of its subtickets first. Now re-adding them.

#14 Updated by kytv about 4 years ago

  • Target version changed from Tails_1.4.1 to Tails_1.5

#15 Updated by intrigeri about 4 years ago

  • Description updated (diff)

#16 Updated by kytv about 4 years ago

  • Related to Bug #9715: Retry wget in the test suite when failing to resolve a host added

#17 Updated by kytv about 4 years ago

  • Related to deleted (Bug #9715: Retry wget in the test suite when failing to resolve a host)

#18 Updated by kytv almost 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

#19 Updated by kytv almost 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.7

#20 Updated by intrigeri almost 4 years ago

[...] is already problematic, and is blocking deployment in our Jenkins infrastructure (#8539)

This deployment is happening.

#21 Updated by kytv over 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (kytv)

Marking as resolved since all subtickets have been resolved.

Also available in: Atom PDF