Project

General

Profile

Feature #9489

Feature #5926: Freezable APT repository

Implement packages importing and freezing

Added by intrigeri over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
12/13/2015
Due date:
% Done:

100%

Feature Branch:
feature/5926-freezable-APT-repository
Type of work:
Code
Starter:
Affected tool:

Description

This includes:

  1. design, implement and document centralization and merging of the list of needed packages (e.g. topic branches can pull more packages in), if we decide to import only a subset of the Debian suites we're interested in
  2. set up and configure the chosen tools
  3. do a first import
  4. make it easy or automated to import foreign packages and freeze APT suites, whenever relevant during the dev and release cycle
  5. update build process accordingly
  6. update release process documentation accordingly

Subtasks will follow when we start working on it.


Subtasks

Feature #6296: Configure reprepro to pull from foreign APT repositoriesResolved

Feature #6299: Regularly pull packages from foreign APT repositoriesResolved

Feature #6297: Save list of packages used at ISO build timeDuplicate

Feature #6303: Adapt our infrastructure to be able to handle tons of packagesResolved

Feature #10851: Give lizard enough free storage to host our freezable APT repositoryResolved

Feature #10748: Generate a manifest of packages used at build timeResolved

Feature #10749: Create partial APT snapshot from a build manifest and a set of time-based snapshotsResolved

Feature #11444: Write contributors doc for the freezable APT repositoryResolved

Feature #11446: Document freeze exceptions workflow for the freezable APT repositoryResolved

History

#2 Updated by intrigeri over 4 years ago

  • Description updated (diff)

#4 Updated by intrigeri almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Blueprint set to https://tails.boum.org/blueprint/freezable_APT_repository/

#5 Updated by intrigeri almost 4 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#6 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#7 Updated by intrigeri over 3 years ago

  • Feature Branch set to feature/5926-freezable-APT-repository

#8 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA

Remaining bits are listed on https://tails.boum.org/blueprint/freezable_APT_repository/#todo, everything else is ready IMO, so let's please review this, and we'll discuss during our meeting today what else is blocking the merge.

#9 Updated by anonym over 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

To get some more exposure of this before the 2.4 freeze I decided to merge this early, despite some minor comments/suggestions/improvements. See the review-feature/5926-freezable-APT-repository branch on my repo git.tails.boum.org:anonym/tails. The "XXX" commits just adds comments, that you can clarify here if needed; the other commits are suggested fixes/improvements that you can cherry-pick straight into devel, if you agree.

#10 Updated by intrigeri over 3 years ago

  • QA Check changed from Dev Needed to Pass

I've reviewed and merged your changes, and addressed with cfe8f10 and b034cb8 the few XXX you had added, so we're done here! I can't close this ticket since it has a few remaining subtasks though.

#11 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)

We're done here! Many thanks to anonym & bertagaz for the quick & high quality reviews :)

#13 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF