Project

General

Profile

Feature #9488

Feature #5926: Freezable APT repository

Feature #9487: Research what solution to use for the freezable APT repository

Specify how we want to sync packages from Debian

Added by intrigeri over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
05/28/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Starter:
Affected tool:

Description

More specifically: which packages? when? into which APT suite(s)? Think about it, come up with a proposal, discuss this with the community, lead this discussion to a conclusion.

History

#2 Updated by intrigeri over 4 years ago

  • Target version changed from 246 to Tails_1.8

#3 Updated by intrigeri over 4 years ago

  • Priority changed from Elevated to Normal

#4 Updated by intrigeri over 4 years ago

On #9508#note-1, I've added estimates of how much disk space various solutions would eat. This lead me to think a bit about importing selected packages only vs. importing entire APT dists, and my current take on this is that the latter is much more attractive a solution. In general, in wouldn't make much difference, but there are use cases in which the latter solution makes the workflow trivial, while the other makes it hard to deal with: e.g. say I'm working on a topic branch that installs additional Debian packages; if we're importing entire APT dists, then regardless of which stage of Tails development we are in (frozen or not), then it'll just work since the newly needed package is already part of the mirror we're using; OTOH, if we're importing only the packages we think we need, then working on such a topic branch requires either that I have the credentials to import new packages from Debian into our own mirror (which raises the barrier for contributing), or that during some phases of Tails development the regular Debian archive is used instead of our own mirror (which makes it harder 1. to reason about when to freeze our own mirror, when working on this ticket; 2. to understand in which exact situation I can do what I want to, or not, when working on a topic branch). A policy of "no new packages added except on branches forked off devel" would solve this, and seems nice in theory, but I doubt it'll work in practice, as there are probably cases when a bugfix branch that targets stable or testing needs to pull new packages, for some reason.

#6 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Blueprint set to https://tails.boum.org/blueprint/freezable_APT_repository/

An initial description of the problem, available options, and chosen design can be found on the blueprint.

#7 Updated by intrigeri about 4 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

#8 Updated by intrigeri about 4 years ago

  • Priority changed from Normal to Elevated

I should submit our proposal to Tails developers soonish, so that we have time to address any fundamental design issues they might point us to.

#9 Updated by intrigeri almost 4 years ago

  • Priority changed from Elevated to High
  • Target version changed from Tails_2.0 to Tails_2.2

#10 Updated by intrigeri almost 4 years ago

  • Target version changed from Tails_2.2 to Tails_2.3
  • % Done changed from 10 to 50

#11 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA

#12 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

There we go!

Also available in: Atom PDF