Project

General

Profile

Feature #9485

Feature #5734: Monitor servers

Update the local dev environment to replicate our monitoring setup

Added by intrigeri over 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
05/28/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

This should be done with Puppet, once #9483 is done. The idea is to enable DrWhax to contribute fixes/improvements later on, which is needed given he's responsible to deliver a working configuration.

History

#1 Updated by intrigeri over 4 years ago

  • Blocked by Feature #9483: Puppetize the monitoring setup prototype added

#3 Updated by intrigeri almost 4 years ago

  • Assignee changed from Dr_Whax to bertagaz
  • Target version changed from Tails_1.8 to Tails_2.0

#4 Updated by bertagaz almost 4 years ago

  • Blocked by deleted (Feature #9483: Puppetize the monitoring setup prototype)

#5 Updated by bertagaz almost 4 years ago

  • Subject changed from Set up a local dev environment replicating our monitoring setup to Update the local dev environment to replicate our monitoring setup
  • Target version changed from Tails_2.0 to Tails_2.2

Postponing this part of the monitoring setup, as it will be unlikely done for the previously planed deadline.

#6 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#7 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#8 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#10 Updated by intrigeri over 3 years ago

  • Assignee deleted (bertagaz)

Given bertagaz did the work, I don't see the point of this ticket. But you've been kept it open and postponed it regularly since 6 months, so perhaps there is something relevant I've missed? Please clarify what this is about.

#11 Updated by intrigeri over 3 years ago

  • Assignee set to bertagaz

#12 Updated by bertagaz over 3 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check set to Info Needed

intrigeri wrote:

Given bertagaz did the work, I don't see the point of this ticket. But you've been kept it open and postponed it regularly since 6 months, so perhaps there is something relevant I've missed? Please clarify what this is about.

Not sure you missed something, I was just not sure about this ticket and its expectations. The point was not clear to me either, so I assumed it was to test the deployment from scratch as we did for Jenkins. Not sure it's worth doing so though, given this feature has been deployed with tiny steps, and Icinga2 was deployed only on half of our VMs at first, and at the end on the other half, precisely to test how from scratch deployment goes.

#13 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to bertagaz

Thanks for adding some more input. Now, we need a decision so please clarify what you think is best, and encode it into Redmine :)

#14 Updated by bertagaz over 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (bertagaz)
  • QA Check deleted (Info Needed)

intrigeri wrote:

Thanks for adding some more input. Now, we need a decision so please clarify what you think is best, and encode it into Redmine :)

Well then, to me better close this ticket.

#15 Updated by bertagaz over 3 years ago

  • % Done changed from 0 to 100

#16 Updated by intrigeri over 3 years ago

  • Status changed from Resolved to Rejected

(I don't think we actually did it: we decided we didn't need to.)

Also available in: Atom PDF