Project

General

Profile

Feature #9482

Feature #5734: Monitor servers

Create a monitoring setup prototype

Added by intrigeri over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
01/09/2015
Due date:
11/09/2015
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Once we've decided what tools we want to use (#8645), and the VM used for experiments has been reset (#9481), we should start from scratch and create a monitoring setup that satisfies our needs. This ticket includes:

  • installing the monitoring software
  • configuring the monitoring software

All this shall be done with Puppet.

icinga2.txt View (4.87 KB) Dr_Whax, 11/06/2015 06:16 AM


Subtasks

Feature #8648: Initial set up of the monitoring softwareResolved

Feature #11194: Install a web interface to our monitoring softwareResolved

Feature #8650: Configure monitoring for the most critical servicesResolved

Feature #8653: Configure monitoring for other high-priority servicesResolved

Feature #11282: Set up personal login for each sysadmin on icingaweb2Resolved

Feature #11358: Set relevant check_interval and retry_interval for hosts and servicesResolved

Bug #11368: Check if Icinga2 perfdata are garbage collectedResolved


Related issues

Blocked by Tails - Feature #9481: Reset the VM used for monitoring tools experiments to a clean state Resolved 05/28/2015

History

#2 Updated by intrigeri over 4 years ago

  • Blocked by Feature #9481: Reset the VM used for monitoring tools experiments to a clean state added

#3 Updated by intrigeri over 4 years ago

  • Blocks Feature #9483: Puppetize the monitoring setup prototype added

#4 Updated by Dr_Whax over 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.5

#5 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

At least one subtask (#8653) is for 1.6, so this can't be for 1.5.

#6 Updated by bertagaz about 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.7

#7 Updated by Dr_Whax about 4 years ago

  • Target version changed from Tails_1.7 to Tails_1.8

#8 Updated by Dr_Whax about 4 years ago

I have attached which packages has to be installed and from which repo, configuring some steps is next.

#9 Updated by intrigeri almost 4 years ago

  • Assignee changed from Dr_Whax to bertagaz
  • Target version changed from Tails_1.8 to Tails_2.0

Dr_Whax wrote:

I have attached which packages has to be installed and from which repo,

Thanks!

configuring some steps is next.

FYI, it can totally be useful if we get it before December 17. If it arrives later, then likely we'll have re-done this work.

#10 Updated by intrigeri almost 4 years ago

I had to turn off the VM because /var/spool/icinga2 ate all available inodes.

#11 Updated by bertagaz almost 4 years ago

  • Blocks deleted (Feature #9483: Puppetize the monitoring setup prototype)

#12 Updated by intrigeri almost 4 years ago

  • Description updated (diff)

#13 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#14 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#15 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress

#16 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#17 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • QA Check set to Pass

I think we're done here :)

Also available in: Atom PDF