Project

General

Profile

Bug #9408

Make sure that we have no regression wrt. logging into a text console on Jessie

Added by intrigeri over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/15/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

I've seen a passwordless login work on tty1. I suspect the session crashed when I switched to tty1, and then the greeter's session cleanup script might have done something that implies this behaviour. We should compare with Tails/Wheezy:

  • with/without an admin password set
  • before/after being logged in via Tails greeter
  • passwordless / with live password

History

#1 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 50

Tails 1.7:

  • from the greeter screen, ctrl-alt-f1 => no automatic login but I can login as user amnesia with password "live"
  • once logged in:
    • with no admin password set: ctrl-alt-f1 => no automatic login but I can login as user amnesia with password "live"
    • with an admin password set: ctrl-alt-f1 => no automatic login but I can login as user amnesia with the configured password

Current feature/jessie:

  • from the greeter screen, ctrl-alt-f1 => no automatic login but I can login as user amnesia with password "live"
  • once logged in:
    • with no admin password set: ctrl-alt-f1 => no automatic login but I can login as user amnesia without a password
    • with an admin password set: ctrl-alt-f1 => no automatic login but I can login as user amnesia with the configured password

So as long as we don't provide screen locking functionality there's no regression here since Wheezy, considering that the default "live" password is public information. I'll come back to it since I wonder if we could easily randomize that password, though.

#2 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

Also available in: Atom PDF