Project

General

Profile

Bug #9375

Pidgin XMPP test fails with 'No handlers could be found for logger "jabberbot"'

Added by intrigeri over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
05/12/2015
Due date:
% Done:

100%

Feature Branch:
kytv:test/9375-jabberbot-logger
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Instant Messaging

Description

While testing 1.4:

  @check_tor_leaks
  Scenario: Chatting with some friend over XMPP                            # features/pidgin.feature:17
    When I start Pidgin through the GNOME menu                             # features/step_definitions/pidgin.rb:252
    Then I see Pidgin's account manager window                             # features/step_definitions/pidgin.rb:263
    When I create my XMPP account                                          # features/step_definitions/pidgin.rb:21
    And I close Pidgin's account manager window                            # features/step_definitions/pidgin.rb:268
    Then Pidgin automatically enables my XMPP account                      # features/step_definitions/pidgin.rb:43
No handlers could be found for logger "jabberbot" 
    Given my XMPP friend goes online                                       # features/step_definitions/pidgin.rb:49
      FindFailed: can not find PidginFriendOnline.png on the screen.
      Line ?, in File ? (RuntimeError)
      features/pidgin.feature:23:in `Given my XMPP friend goes online'

Associated revisions

Revision fb395b6c
Added by anonym over 4 years ago

Merge branch 'test/9375-jabberbot-logger' into stable

Fix-committed: #9375

History

#2 Updated by kytv over 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from kytv to intrigeri
  • % Done changed from 0 to 20
  • QA Check set to Ready for QA
  • Feature Branch set to kytv:test/9375-logger

Unfortunately I've not been able to reproduce this.

I've tested the possible fix from anonym's link (cheers!) and it hasn't broken anything for me. I'm optimistically hopeful that the simple change will resolve the problem for you.

    When I create my XMPP account                                          # features/step_definitions/pidgin.rb:36
[log] CLICK on (711,509)
    And I close Pidgin's account manager window                            # features/step_definitions/pidgin.rb:283
calling as amnesia: xdotool search --name 'Buddy List' windowactivate --sync
call returned: [0, "", ""]
    Then Pidgin automatically enables my XMPP account                      # features/step_definitions/pidgin.rb:58
calling as amnesia: xdotool search --name 'Buddy List' windowactivate --sync
call returned: [0, "", ""]
    Given my XMPP friend goes online                                       # features/step_definitions/pidgin.rb:64
calling as amnesia: xdotool search --name 'Buddy List' windowactivate --sync
call returned: [0, "", ""]
[log] DOUBLE CLICK on (170,245)
    When I start a conversation with my friend                             # features/step_definitions/pidgin.rb:80
calling as amnesia: xdotool search --name 'kytvtails' windowactivate --sync
call returned: [0, "", ""]
[log] TYPE "ping
" 
    And I say something to my friend                                       # features/step_definitions/pidgin.rb:97
calling as amnesia: xdotool search --name 'kytvtails' windowactivate --sync
call returned: [0, "", ""]
    Then I receive a response from my friend  

#3 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to kytv
  • % Done changed from 20 to 50
  • QA Check changed from Ready for QA to Dev Needed

Cool, thanks. I haven't seen the problem again, but that change seems to make sense. Please make it compliant with Python best practices (this branch adds non-import code to the import block, which is not compliant with PEP8 iirc), and then I'll test and merge.

#4 Updated by kytv over 4 years ago

  • Target version changed from Tails_1.4.1 to Tails_1.5

#5 Updated by kytv over 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

#6 Updated by kytv over 4 years ago

  • % Done changed from 50 to 60
  • Feature Branch deleted (kytv:test/9375-logger)

Now I can reproduce the error. It doesn't cause the test to fail for me, however.

I think I've got this fixed (yay!) but I'll do a fair amount of testing before declaring victory

#7 Updated by kytv over 4 years ago

  • Assignee changed from kytv to anonym
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch set to kytv:test/9375-jabberbot-logger

#8 Updated by kytv over 4 years ago

Note that the

No handlers could be found for logger "jabberbot" 

error is easily reproducible on isotester1 but it does not cause the test to fail.

An example:

  @check_tor_leaks
  Scenario: Chatting with some friend over XMPP in a multi-user chat           # features/pidgin.feature:24
    Given Tails has booted from DVD and logged in and the network is connected # features/step_definitions/snapshots.rb:208
    When I start Pidgin through the GNOME menu                                 # features/step_definitions/pidgin.rb:276
    Then I see Pidgin's account manager window                                 # features/step_definitions/pidgin.rb:285
    When I create my XMPP account                                              # features/step_definitions/pidgin.rb:50
    And I close Pidgin's account manager window                                # features/step_definitions/pidgin.rb:289
    Then Pidgin automatically enables my XMPP account                          # features/step_definitions/pidgin.rb:71
    When I join some empty multi-user chat                                     # features/step_definitions/pidgin.rb:147
    And I clear the multi-user chat's scrollback                               # features/step_definitions/pidgin.rb:188
No handlers could be found for logger "jabberbot" 
    And my XMPP friend goes online and joins the multi-user chat               # features/step_definitions/pidgin.rb:76
    Then I can see that my friend joined the multi-user chat                   # features/step_definitions/pidgin.rb:194
    And I say something to my friend in the multi-user chat                    # features/step_definitions/pidgin.rb:107
    Then I receive a response from my friend in the multi-user chat            # features/step_definitions/pidgin.rb:118

This branch fixes the problem for me.

#9 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Dev Needed

kytv wrote:

This branch fixes the problem for me.

The commit message is only "Import logging module in otr-bot.py" and that's indeed what the commit does. I would like an explanation why we have to do this to fix this bug, possibly based on the explanation from the link. History rewrite! :)

#10 Updated by kytv over 4 years ago

  • Assignee changed from kytv to anonym
  • QA Check changed from Dev Needed to Ready for QA

Maybe this is acceptable now… :)

#11 Updated by anonym over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

#12 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

kytv wrote:

Maybe this is acceptable now… :)

It looks perfect except that the end-quote of the error message was missing so I added it myself to spare you from the hassle. :) Merged!

#13 Updated by bertagaz over 4 years ago

  • Status changed from 11 to Resolved
  • QA Check deleted (Pass)

Also available in: Atom PDF