Project

General

Profile

Bug #9344

Bug #8059: Windows Camouflage automated tests sometimes failed due to differently ordered icons in the notification area

Bug #9095: Seahorse tests lack robustness

Sometimes Seahorse's Find keys dialog cannot be found during tests

Added by anonym over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
05/05/2015
Due date:
% Done:

100%

Feature Branch:
kytv:test/9344-seahorse-findkey
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The failure log is:

  Scenario: Fetching OpenPGP keys using Seahorse via the Tails OpenPGP Applet should work and be done over Tor. # features/torified_gnupg.feature:30
    When I fetch the "10CC5BC7" OpenPGP key using Seahorse via the Tails OpenPGP Applet                         # features/step_definitions/torified_gnupg.rb:97
      FindFailed: can not find SeahorseFindKeysWindow.png on the screen.

It happens before any network interaction, so it's purely a Sikuli vs GUI issue.


Related issues

Blocked by Tails - Bug #9355: More robust accessing the gpgApplet in the test suite Resolved 05/07/2015

Associated revisions

Revision ddd58e9a (diff)
Added by kytv over 4 years ago

Retry accessing menus in Seahorse on failure

(Related to #8298)

Will-fix: #9344

Revision 621fa0a6
Added by anonym over 4 years ago

Merge remote-tracking branch 'kytv/test/9344-seahorse-findkey' into stable

Fix-committed: #9344

History

#2 Updated by kytv over 4 years ago

  • Status changed from Confirmed to In Progress

I've now seen this in two different situations:

  • menu selection failure (looks like #8928, I can't reproduce this in my nested VM with unclutter disabled). I solved this in my workspace.
  • the menu selection is successful, the find window appears, but then it quickly disappears causing the test to fail. (Of course this was seen when I wasn't capturing video.)

As I did for the problem of the keyboard layout not being activated when selected at the greeter (#7912) I'll try reproducing the second bullet point with a custom test scenario.

#3 Updated by kytv over 4 years ago

  • Assignee changed from kytv to anonym
  • % Done changed from 0 to 20
  • QA Check set to Ready for QA
  • Feature Branch set to kytv:test/9344-seahorse-findkey

#4 Updated by kytv over 4 years ago

  • Blocked by Bug #9355: More robust accessing the gpgApplet in the test suite added

#5 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • % Done changed from 20 to 40
  • QA Check changed from Ready for QA to Dev Needed

First of all, I like the addition of the OpenPGPKeyserverCommunicationError exception. I may be that we at some point start to classifying transient network errors like this and then (lower down) make retries when we catch such exceptions (see #9478).

+def menu_click_helper(main, sub, verify = nil)

Defining it like this (which we do all over the place, so no harm there) will add the function to the global namespace, and it is a bit to generic (=> risk for collisions) for that IMHO. What about seahorse_menu_click_helper (similar to the seahorse_wait_helper you add later)? Related ticket: #9030.

Otherwise, the tests runs great for me, and the changes make sense. I'll merge once you've done the rename.

#6 Updated by anonym over 4 years ago

anonym wrote:

Defining it like this (which we do all over the place, so no harm there) will add the function to the global namespace, and it is a bit to generic (=> risk for collisions) for that IMHO. What about seahorse_menu_click_helper (similar to the seahorse_wait_helper you add later)? Related ticket: #9030.

Also, please move it into features/step_definitions/encryption.rb.

#7 Updated by kytv over 4 years ago

  • Subject changed from Sometime Seahorse's Find keys dialog cannot be found during tests to Sometimes Seahorse's Find keys dialog cannot be found during tests
  • Assignee changed from kytv to anonym
  • QA Check changed from Dev Needed to Ready for QA

Renames done here and #9355.

#8 Updated by kytv over 4 years ago

#9 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 40 to 100

#10 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#11 Updated by intrigeri about 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF