Project

General

Profile

Feature #9332

Bug #8686: Sometimes notification-daemon aborts, causing desktop notifications to not be displayed

Test that notification-daemon is running

Added by kytv over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
05/03/2015
Due date:
% Done:

100%

Feature Branch:
kytv:test/9332-notification-daemon-running
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Associated revisions

Revision 15c1278d (diff)
Added by kytv over 4 years ago

Check that notification-daemon is running when looking for notifications fails

Will-fix: #9332

Revision dc24a2bb
Added by anonym over 4 years ago

Merge remote-tracking branch 'kytv/test/9332-notification-daemon-running' into stable

Fix-committed: #9332

History

#1 Updated by kytv over 4 years ago

  • Status changed from Confirmed to In Progress

Adding something like

step 'process "notification-daemon" is running' 

to each step that looks for a desktop notification would make it clear that the notification was not displayed because of the bug in #8686.

#2 Updated by kytv over 4 years ago

  • % Done changed from 0 to 10

With what I have in my workspace:

    And I log in to a new session              # features/step_definitions/common_steps.rb:263
    And the Tails desktop is ready             # features/step_definitions/common_steps.rb:309
calling as root: . /usr/local/lib/tails-shell-library/tor.sh; tor_is_working
call returned: [1, "", ""]
calling as root: . /usr/local/lib/tails-shell-library/tor.sh; tor_is_working
call returned: [1, "", ""]
calling as root: . /usr/local/lib/tails-shell-library/tor.sh; tor_is_working
call returned: [0, "", ""]
calling as root: test -e /var/run/tordate/done
call returned: [0, "", ""]
calling as root: test -e /var/run/htpdate/success
call returned: [1, "", ""]
calling as root: test -e /var/run/htpdate/success
call returned: [1, "", ""]
calling as root: test -e /var/run/htpdate/success
call returned: [1, "", ""]
calling as root: test -e /var/run/htpdate/success
call returned: [1, "", ""]
calling as root: test -e /var/run/htpdate/success
call returned: [1, "", ""]
calling as root: test -e /var/run/htpdate/success
call returned: [0, "", ""]
    And Tor is ready                           # features/step_definitions/common_steps.rb:335
calling as root: pidof -x -o '%PPID' notification-daemon
call returned: [1, "", ""]
    Then I see the 'Tor is ready' notification # features/step_definitions/common_steps.rb:329
      Process 'notification-daemon' is not running.
      <false> is not true. (Test::Unit::AssertionFailedError)
      ./features/step_definitions/common_steps.rb:484:in `/^process "([^"]+)" is running$/'
      ./features/step_definitions/common_steps.rb:46:in `rescue in notification_helper'
      ./features/step_definitions/common_steps.rb:43:in `notification_helper'
      ./features/step_definitions/common_steps.rb:331:in `/^I see the 'Tor is ready' notification$/'
      features/noti.feature:14:in `Then I see the 'Tor is ready' notification'

#3 Updated by kytv over 4 years ago

  • Assignee changed from kytv to anonym
  • QA Check set to Ready for QA
  • Feature Branch set to kytv:test/9332-notification-daemon-running

#4 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Dev Needed

I believe you have forgotten to push the branch.

I think doing this definitely makes sense. However, I am afraid that we will en up making the test suite a lot less "robust" for a few more months given that we have decided (IIRC) to not care about fixing the actual issue since it's fixed in Jessie. Any way, push and I'll give it a few complete runs. In the end, if it turns out to fail to many tests needlessly in Wheezy-based Tails, then we may temporarily just make it print a warning in case notification-daemon isn't running.

#5 Updated by kytv over 4 years ago

  • Assignee changed from kytv to anonym
  • QA Check changed from Dev Needed to Ready for QA

anonym wrote:

I believe you have forgotten to push the branch.

Hmm.

$ git push cz 
Everything up-to-date

And I see it at http://repo.or.cz/w/tails/kytv.git/shortlog/refs/heads/test/9332-notification-daemon-running

Passing back, hoping it's visible.

#6 Updated by anonym over 4 years ago

kytv wrote:

anonym wrote:

I believe you have forgotten to push the branch.

Hmm.

[...]

And I see it at http://repo.or.cz/w/tails/kytv.git/shortlog/refs/heads/test/9332-notification-daemon-running

Passing back, hoping it's visible.

My bad, my fetch failed and I didn't notice it.

#7 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 10 to 100
  • QA Check changed from Ready for QA to Pass

Ah! I like the idea to only check whether notification-daemon is running if we fail to find some expected notification. That makes my concerns in #9332#note-4 moot. Will merge!

#8 Updated by kytv over 4 years ago

  • Status changed from Fix committed to In Progress

#9 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed

#10 Updated by kytv over 4 years ago

anonym wrote:

Ah! I like the idea to only check whether notification-daemon is running if we fail to find some expected notification. That makes my concerns in #9332#note-4 moot. Will merge!

Woohoo. (This was the best way that I could think of doing this.)

#11 Updated by intrigeri over 4 years ago

anonym wrote:

Ah! I like the idea to only check whether notification-daemon is running if we
fail to find some expected notification. That makes my concerns in #9332#note-4
moot. Will merge!

Woohoo. (This was the best way that I could think of doing this.)

Congrats!

#12 Updated by intrigeri about 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF