Project

General

Profile

Bug #9326

Feature #7377: Improve Windows 8 camouflage

Tor Browser win8 theme regressions

Added by anonym over 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Camouflage
Target version:
-
Start date:
05/02/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

In Tails 1.2 two unintended changes were introduced in the Tor Browser win8 theme:

  • The tab bar isn't on the right of the URL bad any more, but above it
  • The search bar is enabled

This was when we moved from a Tor Browser based on Firefox 24 to Firefox 31, which changed the tab bar and UI significantly (or some intermediate Firefox version did). In FF24 the tab bar could be moved through the normal customization, but I'm unsure if it's at all possible any more in FF31+ without extensions. Disabling the search bar can easily be done like it was for the I2P Browser (config/chroot_local-includes/usr/share/tails/i2p-browser/userChrome.css).

This issue affects the "normal" Tor Browser as well as the chroot browsers.

History

#1 Updated by anonym over 4 years ago

FWIW adding
#TabsToolbar{-moz-box-ordinal-group:10000!important}

to userChrome.css moves the tab bar under the url bar, so some customization is possible (source and I have verified that it works). So, can such hacks be used to:
  • move it to the right of the url bar?
  • change its "theme" to one with less "rounded" tabs, like in our previous theme (and Window 8 IE)?

#2 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check set to Info Needed

I've seen you hack userChrome.css before. Got any ides?

#3 Updated by intrigeri over 4 years ago

My current take on this is: do another round of websearching + testing IE themes for FF (we're currently crafting our own). If success, then this might fix this ticket. If failure, then IMO this ticket becomes low-prio.

#4 Updated by anonym over 4 years ago

  • Priority changed from Normal to Low
  • Target version deleted (Tails_1.4)

intrigeri wrote:

My current take on this is: do another round of websearching + testing IE themes for FF (we're currently crafting our own). If success, then this might fix this ticket. If failure, then IMO this ticket becomes low-prio.

I looked around for 15 minutes, found the same old themes for IE <10 that we investigated in the Tails 1.1 cycle, when developing the Windows 8 theme. I'm not surprised -- who in their right mind would want something like that? ;)

Giving up.

#5 Updated by BitingBird over 4 years ago

  • Category set to Camouflage
  • Assignee deleted (kytv)
  • QA Check deleted (Info Needed)

#6 Updated by BitingBird over 4 years ago

  • Assignee set to kytv
  • QA Check set to Info Needed

#7 Updated by kytv over 4 years ago

I'm not confident that I'll be able to make any headway with this but I can give it a shot. My previous userChrome.css work was done with the aid of ÐomInspector and once I had the necessary IDs the hidden bit was a cinch.

(I expect to unassign this in a week or so after giving up but who knows)

#8 Updated by kytv over 4 years ago

  • Assignee deleted (kytv)

After poking around at this a bit, unfortunately I don't know how to fix this.

anonym wrote:

Giving up.

Me too.

#9 Updated by intrigeri over 4 years ago

  • QA Check deleted (Info Needed)

#10 Updated by BitingBird over 3 years ago

#11 Updated by u over 2 years ago

  • Status changed from Confirmed to Rejected

I think we can for the time being reject this. We don't ship Camouflage currently, and I doubt that this ticket will be useful if ever we do again, because likely the code base will have changed.

#12 Updated by u over 2 years ago

  • Related to deleted (Feature #7377: Improve Windows 8 camouflage)

#13 Updated by u over 2 years ago

  • Parent task set to #7377

Also available in: Atom PDF