Project

General

Profile

Feature #9308

What do we do for people coming from search engines inside the assistant

Added by tchou over 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
04/30/2015
Due date:
% Done:

100%

Feature Branch:
feature/9308-dont-index-installation-instructions
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

If we do nothing special, people could crash on random pages in the Tails Installer Assistant. At some point it could be problematic, for example someone using firefox on a tablet comes in the "Linux/Install Tails Downloader" extension. A user starting at the begining of the assistant would have been routed to a specific path (no scenario for you, sorry).

We could :
- unindex all the internal pages of the assistant. We don't have this probleme anymore, but we have an other problem : maybe we could like to have some of this pages indexed to get have some traffic.
or
- have some warning or reminders in some pages. In wich page ?


Related issues

Blocks Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Resolved 03/09/2018

Associated revisions

Revision 442713d2 (diff)
Added by sajolida almost 2 years ago

Don't index pages of the installation assistant (Will-fix: #9308)

They don't have much navigation so people coming from search engines
might be lost. Also, see the steps without seeing the overview would be
a handicap.

It's a shame because the installation scenarios are well referenced by
search engines.

Revision be7f91b8 (diff)
Added by sajolida almost 2 years ago

Don't index pages of the installation assistant (Will-fix: #9308)

They don't have much navigation so people coming from search engines
might be lost. Also, see the steps without seeing the overview would be
a handicap.

It's a shame because the installation scenarios are well referenced by
search engines.

History

#1 Updated by BitingBird over 4 years ago

  • Subject changed from what do we don't for people comming from search engines inside the assistant to what do we don't for people coming from search engines inside the assistant
  • Category set to Installation

#2 Updated by BitingBird over 4 years ago

  • Subject changed from what do we don't for people coming from search engines inside the assistant to What do we do for people coming from search engines inside the assistant

#3 Updated by sajolida over 4 years ago

  • Status changed from New to Confirmed
  • Assignee set to tchou
  • QA Check set to Info Needed

I think that:

  • The pages from inside the route shouldn't be indexed by search engines (and if they are it's probably no big deal).
  • The overviews and steps can be indexed with no problem as they are supposed to make it clear what we are doing and where we are.
  • The overview should make it clear which scenario has been selected.
  • The steps should have a reminder of the scenario.

#4 Updated by BitingBird over 4 years ago

  • Affected tool set to ISO Verification Extension

#5 Updated by sajolida over 4 years ago

  • Affected tool deleted (ISO Verification Extension)

The web assistant is different from the ISO verification extension. We probably miss an "affected tool" for it. I'll ask tails-sysadmins.

#6 Updated by BitingBird over 4 years ago

oops sorry

#7 Updated by sajolida over 4 years ago

  • Affected tool set to Installation Assistant

#8 Updated by sajolida over 4 years ago

  • Priority changed from Normal to Low

#9 Updated by sajolida about 4 years ago

  • Priority changed from Low to Normal
  • Target version set to 246

#10 Updated by sajolida about 4 years ago

  • Parent task deleted (#9196)

#11 Updated by sajolida about 4 years ago

  • Parent task set to #8592

#12 Updated by sajolida about 4 years ago

  • Target version changed from 246 to Tails_2.0

#13 Updated by sajolida about 4 years ago

  • Target version deleted (Tails_2.0)
  • Parent task deleted (#8592)

Let's say this is a bonus and not a blocker for the first release.

#14 Updated by intrigeri almost 2 years ago

  • Assignee deleted (tchou)
  • QA Check deleted (Info Needed)

#15 Updated by sajolida almost 2 years ago

  • Assignee set to sajolida
  • Target version set to Tails_3.7

#16 Updated by sajolida almost 2 years ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#17 Updated by sajolida almost 2 years ago

  • Assignee changed from sajolida to u
  • QA Check set to Ready for QA
  • Feature Branch set to feature/9308-dont-index-installation-instructions

Here is a branch!

feature/9308-dont-index-installation-instructions

Ulrike: Same as #15114#note-3. I think this is core UX.

#18 Updated by sajolida almost 2 years ago

  • Status changed from Confirmed to In Progress

#19 Updated by u over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (u)
  • % Done changed from 0 to 100
  • QA Check deleted (Ready for QA)

LGTM. Merged into master.

Also available in: Atom PDF