Project

General

Profile

Feature #9295

Bug #7552: Firefox extension to automatically verify the ISO checksum

Bug #6851: Fix ISO verification using checksum

Find a name for the download extension

Added by sajolida over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/29/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:
ISO Verification Extension

Description

We need a name for our browser extension. Ideally before people start writing the code for real.

History

#1 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to tchou
  • QA Check set to Info Needed

From the top of my head:

- Tails Download
- Tails Downloader
- Tails Download & Verify

Tchou: what do you think?

#2 Updated by tchou over 4 years ago

I had a look quickly on addons.mozilla.org seaching for "download" and "downloader". I did not make real metrics, but both terms are used (in quite "big" addons).

I prefere "Tails Downloader", without real arguments.

#3 Updated by sajolida over 4 years ago

  • Assignee changed from tchou to DS
  • QA Check changed from Info Needed to Ready for QA

I think that the idea that the extension is not only downloading but also verifying is important to convey. Even though the verification is made transparent to the user, the download itself doesn't justify installing an extension; only the verification does. Users might otherwise wonder why they are requested to install an extension just to download a file.

So we're now proposing:

- Tails Secure Downloader

Diddly-Squat, do you mind having a look?

#4 Updated by DS over 4 years ago

"Tails Download and Verify" would seem to be quite appropriate. "Secure" would be quite ambiguous in English so I could only assume the same in other languages. I might even go so far as to say "Tails Download and Verify Checksum" if there were enough space to accomodate the title.

I think it would be hard to find amiguity in "Tails Download and Verify Checksum".

#5 Updated by DS over 4 years ago

I correct myself:

I think it would be hard to find amiguity in "Download Tails with Verified Checksum".

If that's too long, perhaps all that's needed is "Download with Verified Checksum".

#6 Updated by ma1 over 4 years ago

I'd vote for "Download and Verify Tails".
Unambiguous and future-proof, in case we change the verification process.

#7 Updated by sajolida over 4 years ago

  • Assignee changed from DS to tchou

I'm following you on this. "Secure" is not good. Now I'm doubting between "Tails Download and Verify" as suggested by DS and "Download and Verify Tails" as suggested by ma1.

Is it common or all-right for Firefox extensions to be structured like a sentence rather than like a noun? I've found a few ones like "Download YouTube Videos as MP4" and "Download Flash and Video", so I guess it's all-right.

I personally don't care. Both are fine with me.

Assigning to tchou to get his opinion.

#8 Updated by tchou over 4 years ago

  • Assignee changed from tchou to sajolida

Maybe "Download and Verify Tails",rather than "Tails Download and Verify" because it's closest to the action, and more clear that it's not about using Tails, it's for before you use it.

#9 Updated by intrigeri over 4 years ago

Maybe "Download and Verify Tails",rather than "Tails Download and Verify" because
it's closest to the action, and more clear that it's not about using Tails, it's for
before you use it.

+1, for what it's worth.

#10 Updated by sajolida over 4 years ago

  • Parent task deleted (#8566)

#11 Updated by sajolida over 4 years ago

  • Parent task set to #7552

#12 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to Resolved
  • QA Check changed from Ready for QA to Pass

Ok, let's go for this one then: "Download and Verify Tails".

#13 Updated by intrigeri over 4 years ago

Ok, let's go for this one then: "Download and Verify Tails".

Woohoo!

Also available in: Atom PDF