Project

General

Profile

Bug #9279

ISO file size unit is not translatable on the download page

Added by intrigeri over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
04/26/2015
Due date:
% Done:

100%

Feature Branch:
doc/9729-translatable-iso-size
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

#7417 introduced the ISO file size on the download page, in a way that the unit (currently: MB) is not translatable. I didn't see that as a blocker for merging, but still it would be nice to fix it.


Related issues

Related to Tails - Feature #7417: Mention the ISO file size on the download page Resolved 06/17/2014
Related to Tails - Bug #10124: po_translatable_pages is unstable on boum.org Rejected 08/31/2015
Related to Tails - Bug #6907: ikiwiki po plugin does not play well with inline directives Resolved 12/03/2018 03/12/2019

Associated revisions

Revision 6270e848
Added by intrigeri over 4 years ago

Merge branch 'web/9279-translatable-iso-size'

Closes: #9279

Revision 4438a3e9
Added by intrigeri about 4 years ago

Merge remote-tracking branch 'origin/doc/9729-translatable-iso-size'

Closes: #9279

History

#1 Updated by intrigeri over 4 years ago

  • Related to Feature #7417: Mention the ISO file size on the download page added

#2 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee deleted (sajolida)
  • QA Check set to Ready for QA
  • Feature Branch set to web/9279-translatable-iso-size

Here there's a branch ready for QA. This work was in the end very long and frustrating for what it must have been, so if the result is not satisfactory maybe that's an idea we should drop as not realistic with ikiwiki.

#3 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

I'll review it, thanks! (Not sure it'll be done in time for 1.5, who knows.)

This work was in the end very long and frustrating for what it must have been

Sometimes it's OK to just give up if something is too hard to fix properly :)

#4 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Info Needed

Wow, indeed I see why it has been painful.

Here are a few comments:

  • I don't understand what's the purpose of commit:21b6559, and the commit message doesn't help me very much. I looked at the files and it was not obvious what was updated, and I don't know what "compress background" means. (As usual, I'm cautious about binary files changing in Git without a clear reason, you know why ;)
  • In Chromium, I see display glitches that (for me) are regressions compared to current master:
    • the (NNN MB/NNN MiB) text size is quite smaller than without this branch merged, to the point of being quite hard to read; is it intentional?
    • there's no visible space anymore between the number and the unit; is it intentional?
    • the opening parenthesis and the first digit ("9") are stuck very close to each other, while there is some space between "MiB" and the closing parenthesis; it's not very pretty, and doesn't help reading; this is mostly visible in non-English languages.

I don't know which ones exactly should be treated as blockers, but at least I'd like to make sure that you're aware of these problems, and to get your opinion on it.

#5 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Info Needed to Ready for QA
  • I don't understand what's the purpose of commit:21b6559

I shrunk all the margins and some are embedded in the images themselves.
Yeah, that's quite ugly... I rewrote this commit to make this more clear
in Git.

  • the (NNN MB/NNN MiB) text size is quite smaller than without this branch merged, to the point of being quite hard to read; is it intentional?

Now that I shrunk all the margins, I could roll back to the original
text size (12px).

  • there's no visible space anymore between the number and the unit; is it intentional?
  • the opening parenthesis and the first digit ("9") are stuck very close to each other, while there is some space between "MiB" and the closing parenthesis; it's not very pretty, and doesn't help reading; this is mostly visible in non-English languages.

Thanks for your feedback. After a couple of days I felt like tackling
this again. Actually, inlines and translations only add extra visible
spaces in some cases, so I should be smart and compensate for them only
when needed. I rewrote a bit this branch and now it should look neat.

I'm not sure that was worth 3.5 hours of work but this knowledge will
definitely helpful while laying out the Installation Assistant, so
that's not too depressing :)

#6 Updated by intrigeri over 4 years ago

I rewrote a bit this branch and now it should look neat.

Excellent, I'll try to look at it shortly while you still have the problem space in mind... but no promise, and it may have to wait after DebConf, so if I'm lagging behind too much, feel free to look for another reviewer.

I'm not sure that was worth 3.5 hours of work but this knowledge will definitely helpful while laying out the Installation Assistant, so that's not too depressing :)

"Cool" :)

#7 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_1.5 to Tails_1.6

#8 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#9 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#10 Updated by sajolida over 4 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to intrigeri
  • QA Check changed from Pass to Ready for QA

Reopening this ticket as the value we had for "po_translatable_pages" broke the production website. Falling back to something that works everywhere with a0f7b0a. Please review and merge again.

#11 Updated by sajolida over 4 years ago

The production website is broken again today, see https://labs.riseup.net/code/attachments/download/919/Screenshot%20from%202015-08-28%2012_12_05.png.

I rebuilt this branch on my machine wiki ikiwiki-cgi.setup and I can't reproduce this. So, I still think this has something to do with the ikiwiki installed by boum. I'll ping them back.

By the way, I also partially re-reverted the font size with 8c9f254 because otherwise the French button gets wrapped. That needs review and merge as well.

#12 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

I rebuilt this branch on my machine wiki ikiwiki-cgi.setup and I can't reproduce this. So, I still think this has something to do with the ikiwiki installed by boum.

I think you're jumping to conclusions a bit too fast on this one: seeing a successful rebuild of a fresh copy locally doesn't imply that a refresh triggered by a totally different set of Git changes must necessary work as well. There have been quite a few similar problems that are hard or impossible to reproduce in a local setup (that is, with no Git hooks, applying changes incrementally instead of all at once, etc.).

I couldn't reproduce the error here with ikiwiki from sid either (same version as the one run on boum.org, I think), so we can't simply blame that version of ikiwiki.

Back to facts: the current wiki source we feed ikiwiki with isn't supported reliably (not the first time we see that when inlining translatable pages, see #9671 and the issue we've had on the news section of translated homepage since years). That's likely a bug in ikiwiki, and probably in the PO plugin. Sadly, we've not found a reliable way to reproduce it, so it's hopeless to report it and hope it'll be fixed (keeping in mind that the PO plugin maintainer, aka. myself, is missing in action -- sorry about that).

So I don't see what we can do, on the short term, except reverting the source we feed ikiwiki with back to a state that works reliably. We're sadly not in a position where we can expect anyone else to fix the root cause of the problem for us.

#13 Updated by intrigeri over 4 years ago

  • % Done changed from 100 to 60

Merged sajolida's latest improvements, thanks! (But keeping this ticket open as the regression introduced by this branch on the production website hasn't been fixed yet.)

#14 Updated by sajolida over 4 years ago

  • Related to Bug #10124: po_translatable_pages is unstable on boum.org added

#15 Updated by sajolida over 4 years ago

  • Priority changed from Normal to Elevated

Postponing and so raising priority.

#16 Updated by sajolida over 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.7

#17 Updated by sajolida over 4 years ago

  • Related to Bug #6907: ikiwiki po plugin does not play well with inline directives added

#18 Updated by sajolida about 4 years ago

  • Assignee changed from sajolida to intrigeri
  • Priority changed from Elevated to Normal
  • Target version changed from Tails_1.7 to Tails_1.8
  • QA Check changed from Dev Needed to Info Needed

Reassigning this to intrigeri because I'm a bit lost in the process and need some clarification. If I understand correctly, we settled on the fact that the issue that appears when releasing 1.5 (I think) was a symptom of #6907.

So:

  • If we're fine with having this piece of code as susceptible of displaying #6907 again sometimes, then I think we should close this ticket as resolved. Note that for the last release it didn't break so it's not systematic.
  • If we're not fine with having this piece of code a susceptible of displaying #6907 again, then I propose to give up on translating the ISO file size unit. I did a bit of research and I think that the only people on Earth using something else than MB are the French. While Wikipedia says that MB is correct in French as well, though less usual. See the breathtaking https://fr.wikipedia.org/wiki/Byte#Distinction_entre_byte_et_octet.

Lowering priority as I don't think this is much of a big deal.

#19 Updated by sajolida about 4 years ago

  • Target version changed from Tails_1.8 to Tails_1.7

Actually, maybe you want to give your opinion before 1.7 and the next risk of breakage.

#20 Updated by intrigeri about 4 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Info Needed to Dev Needed

"having this piece of code as susceptible of displaying #6907 again sometimes" would be quite bad given what exact part of our website (i.e. what's around the ISO download link) is affected by this specific instance of #6907. So I think that "give up on translating the ISO file size unit" is the best we can do here at the moment.

#21 Updated by sajolida about 4 years ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Ok, then please review commit 0d5c284. The branch web/9279-translatable-iso-size was not on origin anymore so I pushed it again from master+this commit.

#22 Updated by intrigeri about 4 years ago

  • Feature Branch changed from web/9279-translatable-iso-size to doc/9729-translatable-iso-size

The branch web/9279-translatable-iso-size was not on origin anymore so I pushed it again from master+this commit.

For some reason the branch to review was actually pushed under a different name (with a typo'ed ticket number, just to test my Git skills I'm sure :p), but thanks to git branch -a --contains 0d5c284 I found it. Glad you mentioned the commit ID otherwise I would have missed it.

The branch reverts the download page to use wiki/src/inc/stable_i386_iso_size.html, but that file hasn't been updated since Tails 1.5 (since the release process doc didn't update it anymore; not sure why it was still around; anyway). FTR I've double-checked, and thankfully it doesn't matter since the ISO size didn't change (the commit message didn't mention this), so we're good.

A local looks OK, so I'm going to merge this, and double-check how it looks like online.

sajolida: I'll let you get in touch with for the ikiwiki.setup update.

#23 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

#24 Updated by intrigeri about 4 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

A local looks OK, so I'm going to merge this, and double-check how it looks like online.

Looks good online.

#25 Updated by sajolida about 4 years ago

Ok, wrote to . I had checked the ISO size already but yeah, I forgot to mention this to you.

Also available in: Atom PDF