Project

General

Profile

Bug #9261

Tor Browser crashes on key press when read by Orca

Added by sajolida over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Accessibility
Target version:
Start date:
04/18/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/9261-Tor-Browser-a11y
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

To reproduce in Tails 1.3.2:

1. Start Tails (without networking)
2. Start Orca (Applications → Universal Access → Orca) and click Ok to enable default options.
3. Start Tor Browser.
5. Press 'A'.
6. Tor Browser crashes.

Associated revisions

Revision d0e66eba (diff)
Added by intrigeri over 4 years ago

AppArmor: grant Tor Browser access to assistive technologies.

... otherwise, Firefox crashes when Orca is enabled.

Will-fix: #9261

Revision 79681310
Added by anonym over 4 years ago

Merge remote-tracking branch 'origin/bugfix/9261-Tor-Browser-a11y' into devel

Fix-committed: #9261

History

#1 Updated by sajolida over 4 years ago

  • Related to Bug #9260: Orca reads neither Tor Browser nor Thunderbird if started after it added

#2 Updated by BitingBird over 4 years ago

Should that be reported upstream?

#3 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Target version set to Tails_1.4
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/9261-Tor-Browser-a11y

That's caused by AppArmor confinement.

#4 Updated by intrigeri over 4 years ago

#5 Updated by intrigeri over 4 years ago

  • Related to deleted (Bug #9260: Orca reads neither Tor Browser nor Thunderbird if started after it)

#6 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#7 Updated by intrigeri over 4 years ago

  • Assignee set to anonym

We're freezing tomorrow, so explicitly putting this branch on the RM's plate.

#8 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#9 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#10 Updated by BitingBird over 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF