Project

General

Profile

Bug #9138

The chroot browsers have the wrong theme in camouflage mode

Added by anonym over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Camouflage
Target version:
Start date:
03/31/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/9138-chroot-browser-camouflage
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

While it doesn't have the "red, scary" theme, it doesn't have the Internet Explorer theme as expected, but GNOME's default grey theme. This is a regression introduced in Tails 1.3, with the chroot browser refactoring.

Associated revisions

Revision 3ff0cb02 (diff)
Added by anonym over 4 years ago

Make the win8 browser theme compatible with the chroot browsers.

The chroot browsers doesn't live in $HOME/.tor-browser since the
chroot browser refactoring.

Will-fix: #9138

Revision fa86a184
Added by intrigeri over 4 years ago

Merge branch 'bugfix/9138-chroot-browser-camouflage' into stable

Fix-committed: #9138

History

#1 Updated by intrigeri over 4 years ago

  • Assignee set to anonym

#2 Updated by anonym over 4 years ago

  • Subject changed from The Unsafe Browser has the wrong theme in camouflage mode to The chroot browsers have the wrong theme in camouflage mode
  • Status changed from Confirmed to In Progress

It affects both the Unsafe Browser and I2P Browser. Working on a fix.

#3 Updated by anonym over 4 years ago

#4 Updated by anonym over 4 years ago

  • % Done changed from 0 to 40
  • Feature Branch set to bugfix/9138-chroot-browser-camouflage

#5 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • % Done changed from 40 to 50
  • QA Check set to Ready for QA

Works according to my tests.

#6 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

#7 Updated by intrigeri over 4 years ago

  • % Done changed from 50 to 60

Passes code review.

#8 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

#9 Updated by BitingBird over 4 years ago

  • QA Check changed from Ready for QA to Pass

#10 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)

#11 Updated by BitingBird over 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF