Project

General

Profile

Bug #9126

Tor Browser should not have access to the list of recently used documents

Added by nobodysees over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/29/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/9126-deny-tor-browser-access-to-recently-used
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

Altough only Tor Browser folder is accessible by Browser by default,

you can also display your Recently Used files which has BEEN SAVED anywhere else (e.g. Desktop)

Test to upload such a file failed to proceed,
yet is it correct that browser can display your recently used files and documents?

Or should this part display "Permission denied" as well as other parts of running instance besides Tor Browser folder?

This can be reproduced easily while trying to upload any file in Tor Browser.

untitled.png View - Displaying recent files and documents inside of Tor Browser while uploading files (11.9 KB) nobodysees, 03/29/2015 02:20 PM

Associated revisions

Revision 6a06da33 (diff)
Added by intrigeri over 4 years ago

AppArmor: deny Tor Browser access to the list of recently used files.

Will-fix: #9126

Revision d3e0ff86
Added by anonym over 4 years ago

Merge remote-tracking branch 'origin/bugfix/9126-deny-tor-browser-access-to-recently-used' into stable

Fix-committed: #9126

History

#1 Updated by nobodysees over 4 years ago

As far as users can upload files on the net only from Tor Browser folder,
there is no point to be able to see Recently Used.

#2 Updated by intrigeri over 4 years ago

  • Subject changed from Browser can display Recently Used to Browser should not have access to the list of recently used documents
  • Status changed from New to Confirmed
  • Assignee set to intrigeri
  • Target version set to Tails_1.4.1

#3 Updated by BitingBird over 4 years ago

Seems to me like a duplicate of #9048 - am I right or are those different issues?

#4 Updated by intrigeri over 4 years ago

Seems to me like a duplicate of #9048 - am I right or are those different issues?

#9126 is the root cause, which deserves fixing, although not with high priority. #9048 was a bug that would have been caused by #9126, but that we can't reproduce. So no, they are not duplicates.

#5 Updated by intrigeri over 4 years ago

  • Subject changed from Browser should not have access to the list of recently used documents to Tor Browser should not have access to the list of recently used documents

#6 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress

#7 Updated by intrigeri over 4 years ago

  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/9126-deny-tor-browser-access-to-recently-used

#8 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#9 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#10 Updated by anonym over 4 years ago

  • QA Check changed from Ready for QA to Pass

#11 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)

#12 Updated by intrigeri about 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF