Project

General

Profile

Bug #9099

Document that Tails may leave traces in video memory

Added by intrigeri over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
03/23/2015
Due date:
% Done:

100%

Feature Branch:
bitingbird:doc/9099-video_memory
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

See #5356 and in particular the Palinopsia PoC.


Related issues

Related to Tails - Feature #5356: Erase video memory on shutdown Confirmed

Associated revisions

Revision 22a89580
Added by intrigeri over 4 years ago

Merge remote-tracking branch 'bitingbird/doc/9099-video_memory'

Will-fix: #9099

Revision fe92c24e (diff)
Added by intrigeri over 4 years ago

Explain what's the practical consequence.

Will-Fix: #9099

Revision 293778e0 (diff)
Added by intrigeri over 4 years ago

Be less affirmative wrt. VRAM emptying itself.

We have no hard data about how long it takes.

Fix-committed: #9099

History

#1 Updated by intrigeri over 4 years ago

#2 Updated by BitingBird over 4 years ago

  • Assignee set to BitingBird
  • Target version changed from Tails_1.3.2 to Tails_1.4

I'll see if I put it in the warnings, known issues or something else. In any case, it will not be for 1.3.2, there are already too much things to review for it, but it will be in 1.4.

#3 Updated by intrigeri over 4 years ago

I'll see if I put it in the warnings, known issues or something else.

Yay!

In any case, it will not be for 1.3.2, there are already too much things to review for it, but it will be in 1.4.

I think it's urgent enough to:

  • either warrant allowing e.g. me to review it initially, and not necessarily sajolida;
  • or, replace another one of your branches that sajolida is meant to review.

#4 Updated by BitingBird over 4 years ago

After reflexion, it doesn't belong in the warnings, because those are limits of Tails that are going to stay. So I think I'll add it to the known issues.

#5 Updated by BitingBird over 4 years ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails_1.4 to Tails_1.3.2
  • Feature Branch set to bitingbird:doc/9099-video_memory

#6 Updated by BitingBird over 4 years ago

  • Assignee deleted (BitingBird)
  • QA Check set to Ready for QA

Added a section in the known issues, with a link to the ticket. While I was at it, I corrected many things in the known issues page (corrected links to Redmine, added some, consistently placed them after the problem's description, and removed a fixed issue). Those are in different commits, but in the same branch.

Built, looks good, please review and merge.

#7 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

#8 Updated by intrigeri over 4 years ago

  • % Done changed from 0 to 50

#9 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to BitingBird
  • % Done changed from 50 to 60
  • QA Check changed from Ready for QA to Info Needed

I read "As RAM, the VRAM empties itself in minutes after shutdown and all data disappears, so you should shutdown instead if rebooting." <-- reference?

Otherwise, looks good.

#10 Updated by BitingBird over 4 years ago

https://hsmr.cc/palinopsia/ "Mitigation

If you use you computer to access sensitive data, TURN IT OFF after usage, so VRAM is disconnected from power. "

Their attack works when you reboot, not when you start it cold.

I could remove "in minutes" I guess.

#13 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

#14 Updated by intrigeri over 4 years ago

  • Status changed from 11 to Resolved
  • Assignee deleted (BitingBird)
  • QA Check changed from Info Needed to Pass

Merged into master and polished a bit. BitingBird, please have a look at the commits I've added on top of yours.

#15 Updated by BitingBird over 4 years ago

Checked, everything is fine :)

Also available in: Atom PDF