Project

General

Profile

Bug #9089

No support for switchable IGP/GPU

Added by 01 over 4 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Hardware support
Target version:
-
Start date:
03/22/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Debian
Blueprint:
Starter:
Affected tool:

Description

Case:

Macbook Pro 15 Retina Late 2013 uses explicitly dedicated GPU (NVIDIA GeForce GT 750M).
Integrated graphic processor isn't listed at all.

Result: Not being able to switch or turn off discrete card to improve battery life.

Tails version:

Tails 1.3 (Debian/Wheezy)

Desired solution:

Either:

Have Intel Iris Pro graphics processors supported by the kernel
and therefore be able to switch off the discrete one.

Or:

Be able to hardcode this solution into the kernel of Tails by myself
to use explicitly the IGP (Intel Iris Pro Graphics)

Hardware:

Macbook Pro Retina 15 Late 2013
Intel Iris Pro Graphics
NVIDIA GeForce GT 750M with 2GB of GDDR5 memory and automatic graphics switching

Logs:

lspci -v

01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fe9 (rev a1) (prog-if 00 [VGA controller])
Subsystem: Apple Inc. Device 0130
Flags: bus master, fast devsel, latency 0, IRQ 48
Memory at c0000000 (32-bit, non-prefetchable) [size=16M]
Memory at 80000000 (64-bit, prefetchable) [size=256M]
Memory at 90000000 (64-bit, prefetchable) [size=32M]
I/O ports at 1000 [size=128]
Expansion ROM at c1000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting
Capabilities: [420] Advanced Error Reporting
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024
Capabilities: [900] #19
Kernel driver in use: nouveau

cat /proc/version

Linux version 3.16.0-4-amd64 () (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 SMP Debian 3.16.7-ckt4-3 (2015-02-03)

Notes:

There are many services like vgaswitcheroo, acpi_call etc.
However, none of them can work if the IGP (in this case Intel Iris Pro is not listed at all - or recognized by the system?)

rant: https://wiki.archlinux.org/index.php/hybrid_graphics


Related issues

Related to Tails - Bug #7505: Video is broken with switchable graphics Rejected 07/06/2014

History

#1 Updated by intrigeri over 4 years ago

  • Target version deleted (Tails_1.3.2)

#2 Updated by intrigeri over 4 years ago

  • Assignee set to 01
  • QA Check set to Info Needed

Can you reproduce that with our latest experimental Tails/Jessie ISO? (http://nightly.tails.boum.org/build_Tails_ISO_feature-jessie/)

#3 Updated by hellodolly over 4 years ago

I can test Tails/Jessie ISO tonight. Report straight after that. However, I doubt that upgraded grub / kernel is there.

New input:

https://lists.gnu.org/archive/html/grub-devel/2013-12/msg00442.html

https://www.marc.info/?l=grub-deavel&m=141586614924917&w=2

https://github.com/0xbb/gpu-switch

Possible solution direction:
apple_set_os command

Basically Macbook Pros detect system that is being loaded isn't OS X and the hardware recognization differs. Which results into internal GPU powered down.

(from the link above) This prevents the firmware from powering down the integrated graphics
card on some recent 2013 Macbook Pro laptops.

Unfortunately my experiences with Debian / Linux is far far away from average and therefore I have no idea what steps to take to upgrade grub / kernel of Tails via instructions provided in the links above.

#4 Updated by BitingBird over 4 years ago

Any news on that?

#5 Updated by loefa over 4 years ago

Trying Tails/Jessie resulted into NOTHING. Tried few versions, downloads. None of them booted.
Laptop (Macbook Pro Retina) started overheating while trying to process through boot but Tails didn't load.

Current version of Tails still does not provide support for integrated gpu.

Maybe helpful answer on this issue:
https://unix.stackexchange.com/questions/193425/enabling-intel-iris-pro-syslinux-tails-system-macbook-pro-15-retina-late-2013

#6 Updated by intrigeri over 4 years ago

[...] while trying to process through boot but Tails didn't load.

What do you mean exactly by this?

Maybe helpful answer on this issue:
https://unix.stackexchange.com/questions/193425/enabling-intel-iris-pro-syslinux-tails-system-macbook-pro-15-retina-late-2013

Thanks, that's useful. So basically, we'll get these fixes when the patches have been upstreamed into Linux and/or GRUB. Sadly, I doubt we'll have the skills + time to work on it ourselves.

#7 Updated by eripwoip over 4 years ago

command itself: https://github.com/0xbb/gpu-switch

(tested, works. however still only black screen. since igp is powered down.)


patch (chained with grub, refind and hopefully even syslinux)

https://github.com/0xbb/gpu-switch


Any dev that could confirm it is / how is it possible to insert this patch above (.efi) into Tails device.
And insert line into syslinux config that would consider .efi file before boot.

This MAY SOLVE the issue with some hardware on newer Macbooks powered down in Tails.

#8 Updated by eripwoip over 4 years ago

target: enabling igp on newer Macbooks.

#9 Updated by intrigeri over 4 years ago

command itself: https://github.com/0xbb/gpu-switch

Thanks. So a workaround exists and can already be used by affected users, even without modifying Tails. Good!
If you want to see that program included in Tails, next step is to have it part of Debian.

(tested, works. however still only black screen. since igp is powered down.)

I don't understand how it can "work" but still display a black screen. Does running gpu-switch -i lead to a working Tails system on next boot, or not?

patch (chained with grub, refind and hopefully even syslinux)

https://github.com/0xbb/gpu-switch

I'll assume you mean https://github.com/0xbb/apple_set_os.efi instead.

Any dev that could confirm it is / how is it possible to insert this patch above (.efi) into Tails device.

Next steps to make this happen:

  1. research/discuss what the default should be, and how Tails users could choose whether they want to use the integrated or dedicated graphics adapter (I suspect some users will want to use the more powerful NVidia chip, while some others will want to save battery life)
  2. include that apple_set_os.efi EFI program in Debian
  3. adjusts Tails' syslinux configuration to load that EFI program
  4. implement/document whatever was decided regarding users choosing their preferred graphics adapter
  5. make sure it doesn't break anything for non-Mac systems

#10 Updated by intrigeri over 4 years ago

loefa wrote:

Trying Tails/Jessie resulted into NOTHING. Tried few versions, downloads. None of them booted.
Laptop (Macbook Pro Retina) started overheating while trying to process through boot but Tails didn't load.

What did you see happen exactly?

#11 Updated by BitingBird over 3 years ago

  • Priority changed from Normal to Low

#12 Updated by intrigeri about 3 years ago

  • Related to Bug #7505: Video is broken with switchable graphics added

#13 Updated by intrigeri about 3 years ago

  • Status changed from New to Rejected
  • Assignee deleted (01)
  • QA Check deleted (Info Needed)

Lacks info, no progress since a year, closing. #7505 is here anyway.

Also available in: Atom PDF