Project

General

Profile

Bug #9080

Advertise the linguistic capacity of frontdesk

Added by sajolida over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
03/19/2015
Due date:
% Done:

100%

Feature Branch:
doc/9080-support_languages
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

So far there is no mention on the website of which languages are understood and spoken by our support team. Currently we basically receive support requests in the languages into which our website is translated (English, German, French, and Portuguese). But this leads to two problems:

  • People contact us in language that are not spoken by frontdesk.
  • People don't contact us in languages that are spoken by frontdesk but not activated on our website.

A first idea could be to create email addresses (Schleuder lists or emails aliases by language) like Tor does, see https://www.torproject.org/about/contact.html.en.

But our frontdesk team should be consulted about this as their work by shifts. So for example, the people who know French are not always on duty. We could consult them to know whether they would agree on receiving support request in their preferred languages even when they are not on duty.

In the case of Tor, requests in English still represent the vast majority of requests, so this might not so much of a problem. See for example https://lists.torproject.org/pipermail/tor-reports/2015-April/000798.html.


Related issues

Related to Tails - Feature #9799: Have user language information in Whisperback Rejected 07/24/2015

Associated revisions

Revision 53128f4c
Added by sajolida over 4 years ago

Merge branch 'doc/9080-support_languages' (Closes: #9080)

History

#1 Updated by intrigeri over 4 years ago

Thanks for raising this topic!

  • People contact us in language that are not spoken by frontdesk.

Indeed.

  • People don't contact us in languages that are spoken by frontdesk but not activated on our website.

Maybe you've discussed this with frontdesk already (or plan to), but "spoken by frontdesk" may not be enough, given how they organize their shifts.

#2 Updated by BitingBird over 4 years ago

I think that's a very good idea. and, intrigeri: if some, for exemple, spanish or french questions wait a few weeks until a speaker of it turns out, it may be better for people speaking no english than having no answer.

sajolida, do you want me to make a branch or do you prefer to do and merge it directly?

#3 Updated by sajolida over 4 years ago

  • Type of work changed from Website to Discuss

I think we need to raise that topic withing frontdesk first, and see if, for example, we want to provide different email addresses for the different incoming languages. I'll do that.

#5 Updated by sajolida over 4 years ago

  • Description updated (diff)
  • Assignee changed from sajolida to BitingBird

Assiging this to BitingBird who'll be working on related stuff.

Updating the description to be more clear.

#6 Updated by BitingBird over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Wrote to tails-bugs. Let's wait for answers :)

#7 Updated by BitingBird over 4 years ago

Everybody answered and agrees on the idea, we still need to decide how.

#8 Updated by intrigeri over 4 years ago

Is there any discussion left to be had here, or would this be better tracked with Type of work = End-user doc?

#9 Updated by sajolida over 4 years ago

  • Type of work changed from Discuss to End-user documentation

I think this discussion happened but hasn't been summarized here yet by BitingBird.

#10 Updated by BitingBird over 4 years ago

  • Target version set to Tails_1.5

#11 Updated by BitingBird over 4 years ago

Actually, the languages are documented in the contact page(#7698)... I'll add the same sentence in https://tails.boum.org/support/

#12 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to doc/9080-support_languages

Done, please review :)

But... when I build and look at the page, the "email" section of contact goes under the others instead of next to them, I tried to fix it but I don't understand how. I hope you have more html magic than me :)

#13 Updated by BitingBird over 4 years ago

  • Related to Feature #9799: Have user language information in Whisperback added

#14 Updated by sajolida over 4 years ago

  • Target version deleted (Tails_1.5)

#15 Updated by BitingBird over 4 years ago

  • Target version set to Tails_1.6

#16 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Dev Needed

I reviewed your branch. Your content was good, simple enough, etc. Still I shorten it a bit and improved the formatting, see 4c476f6..8c5840a. Tell me what you think.

I didn't see what you referred to with "the 'email' section of contact goes under the others instead of next to them" but maybe 8d1df22 fixed this for you.

I also think we could have this information appear on the WhisperBack documentation as well. If so, then we could create an inline and have it displayed both on /support/talk and /doc/first_steps/bug_reporting. I'm not sure which place of /doc/first_steps/bug_reporting, if in the intro or when talking about the description of the bug request.

Maybe we should work on merging this branch first, and then we can reuse the same inline on /doc/about/contact, otherwise we duplicate information and translators will have to translate the same thing three times.

#17 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida

Your commits improved things and yes, it was probably the html thing that broke it for me.

I agree that it would be nice to have it on bug reporting also. I'd say in the Whisperback section, under "Write the report" because it's about in which language to write :)

Can you manage the inline part? I'm still completely lost with that. If not, I'll try to do it but it might take a while...

I can edit the contact page once we have the inline if I just have to copy&paste :)

#18 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Dev Needed to Ready for QA

Ok, so did all of that. I think it's ready to be merged now! Can you have a final look?

Regarding the inline stuff, I thought you did that alread in the past. But anyway, you can see how it is done in 21f1c54. The trick part for me is to remember that the pages="..." path must be absolute to the root of the website (and not relative). That's all. Maybe we can also try to name all inline with .inline. in their filename. That could make it easier for translators to understand that they are inlines (even though I haven't done that consistenly until now).

#19 Updated by BitingBird over 4 years ago

  • Assignee deleted (BitingBird)
  • % Done changed from 50 to 80
  • QA Check changed from Ready for QA to Pass

The 3 commits look good!

#20 Updated by sajolida over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

#21 Updated by BitingBird over 4 years ago

  • Target version changed from Tails_1.6 to Tails_1.5

#22 Updated by BitingBird over 4 years ago

Youhou !

makes a happy dance

#23 Updated by BitingBird over 4 years ago

  • Assignee set to sajolida

A native suggested to replace "broken english" with "Imperfect english", seems like it's less judgy. Could you do the change ?

#24 Updated by sajolida over 4 years ago

All-right :)

Also available in: Atom PDF