Project

General

Profile

Bug #9072

Bug #8059: Windows Camouflage automated tests sometimes failed due to differently ordered icons in the notification area

Pidgin IRC tests often fail due to OFTC Tor blocking

Added by anonym over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
03/18/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

We need to come up with alternatives here. Whatever we come up with can have some interesting consequences for our default Pidgin account, i.e. if we pick some other way to access OFTC than what it has configured, isn't our Pidgin configuration broken then? OTOH, if we'd apply it to the default Pidgin account, we'd enable spammers/trolls and probably get that method blocked too. Or what if we pick another more Tor-friendly network?

I guess an implication of this situation is that OFTC isn't very suitable for our IRC presence (#tails, #tails-dev etc).


Related issues

Related to Tails - Feature #7874: Find a more stable solution for Tails default chat support channel Resolved 10/28/2015
Blocked by Tails - Bug #9478: How to deal with transient network errors in the test suite? Resolved 05/27/2015
Blocked by Tails - Feature #9517: Retry connecting to OFTC when it fails Resolved 06/02/2015

History

#1 Updated by intrigeri over 4 years ago

  • Related to Feature #7874: Find a more stable solution for Tails default chat support channel added

#2 Updated by intrigeri over 4 years ago

I guess an implication of this situation is that OFTC isn't very suitable for our IRC presence (#tails, #tails-dev etc).

Indeed, but we didn't find any suitable alternative on #7874.

I can't think of a very good solution. The least bad one seems to be:

  • make Pidgin successfully connects to the "irc.oftc.net" account just warn if it can't connect due to OFTC blocking Tor (one needs to look for the "banned" thingie), and limit the consequences of ignoring failures there:
  • move some tests from IRC to XMPP, so that they are not skipped whenever OFTC blocks Tor. In particular:
    • the one about opening a URL from Pidgin.
    • maybe have Using a persistent Pidgin configuration use XMPP instead of IRC

#3 Updated by intrigeri about 4 years ago

  • Assignee set to anonym

#4 Updated by intrigeri about 4 years ago

  • Target version changed from Tails_1.4 to Tails_1.4.1

Postponing.

#5 Updated by anonym about 4 years ago

  • Blocked by Bug #9478: How to deal with transient network errors in the test suite? added

#6 Updated by anonym about 4 years ago

  • Blocked by Feature #9517: Retry connecting to OFTC when it fails added

#8 Updated by anonym about 4 years ago

This one will be fixed via #9517.

#9 Updated by intrigeri about 4 years ago

  • Blocked by deleted (Feature #9517: Retry connecting to OFTC when it fails)

#10 Updated by intrigeri about 4 years ago

  • Blocked by Feature #9517: Retry connecting to OFTC when it fails added

#11 Updated by intrigeri almost 4 years ago

Can this ticket be marked as fix committed, now that #9517 was merged?

#12 Updated by anonym almost 4 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100

intrigeri wrote:

Can this ticket be marked as fix committed, now that #9517 was merged?

Yes!

#13 Updated by intrigeri almost 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF