Project

General

Profile

Feature #9069

Add menu entry to gpgApplet to open gedit directly

Added by IvanBliminse over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/17/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

It would be great if the gpgApplet have an menu entry to open a texteditor (gedit or whatever) directly. Instead of choosing it in the application menu.

addmenuentry.patch View (514 Bytes) IvanBliminse, 03/17/2015 07:16 PM

add_text_editor.patch View (755 Bytes) IvanBliminse, 03/18/2015 11:07 PM

Associated revisions

Revision 9dac94be (diff)
Added by anonym over 4 years ago

Add Gedit shortcut to gpgApplet's context menu (Will-fix: #9069).

Thanks to Ivan Bliminse for the patch.

Revision b8e44458
Added by anonym over 4 years ago

Merge branch 'feature/9069-gpgapplet-menu-with-gedit' into devel

Fix-committed: #9069

History

#1 Updated by BitingBird over 4 years ago

  • Affected tool set to OpenPGP Applet

#2 Updated by IvanBliminse over 4 years ago

#3 Updated by sajolida over 4 years ago

  • Status changed from New to Confirmed
  • Assignee set to anonym
  • % Done changed from 0 to 20
  • QA Check set to Ready for QA
  • Type of work changed from Code to Discuss

I'm not against that, especially now that we have a patch.

The label should be "Open Text Editor".

Marking this as "Code" and assigning to anonym who is the original author of this thing.

anonym, do you think we should do that?

#4 Updated by anonym over 4 years ago

  • Assignee changed from anonym to nodens
  • QA Check changed from Ready for QA to Info Needed

sajolida wrote:

I'm not against that, especially now that we have a patch.

The label should be "Open Text Editor".

Marking this as "Code" and assigning to anonym who is the original author of this thing.

Actually, intrigeri started it, but I added the public key operation support. Nowadays I think nodens is our gpgApplet maintainer (although I may be wrong, please tell me in that case), so I'm reassigning for input. What do you think, nodens?

anonym, do you think we should do that?

Well, it seems a bit bloaty to me. OTOH, if it helps educating users to write their plaintext in Gedit rather than some leak-prone web form, I suppose that's a good thing. I'm not sure, though.

Also, from the patch:

+    my $mtext = Gtk2::MenuItem->new_with_mnemonic($encoding->decode(gettext('_Open Texteditor')));

This should be:

+    my $mtext = Gtk2::MenuItem->new_with_mnemonic($encoding->decode(gettext('_Open Text Editor')));

#5 Updated by nodens over 4 years ago

Hi,

I'm not against it either.
The patch should be updated to launch gnome-text-editor rather than gedit directly, though.

Also, this patch applies against the version currently in Tails but not the master branch in my repository, since the i18n system has changed : https://git-tails.immerda.ch/nodens/openpgp-applet/

(easy enough to adapt).

I'll be happy to do it but may not be able to do it before a week or two. Feel free to provide an updated patch against master in the above repository if you want it to happen faster ;)

Cheers,

#6 Updated by nodens over 4 years ago

  • Type of work changed from Discuss to Code

#7 Updated by nodens over 4 years ago

  • QA Check changed from Info Needed to Dev Needed

#9 Updated by nodens over 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee deleted (nodens)
  • % Done changed from 20 to 40
  • QA Check changed from Dev Needed to Ready for QA

Looks good to me.

I created a topic branch on my repo, to use a slightly modified (gettext is not used anymore directly) : feature/9069-Add_menu_entry_open_text_editor (see previous comment for url).

The patch should apply cleanly on current Tails OpenPGP Applet version, if we want to add this to the devel branch (I don't think my version will be in debian before next release).

Cheers !

#10 Updated by intrigeri over 4 years ago

  • Target version set to Tails_1.4

#11 Updated by anonym over 4 years ago

#12 Updated by anonym over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 40 to 100

#13 Updated by anonym over 4 years ago

  • QA Check changed from Ready for QA to Pass

Merged! This will be part of Tails 1.4. Thanks for your patch, Ivan, and thanks for your input, nodens!

#14 Updated by BitingBird over 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF