Project

General

Profile

Bug #9066

Use convertkey.py from the python-potr package

Added by anonym over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
03/17/2015
Due date:
% Done:

100%

Feature Branch:
test/9066-use-convertkey-from-Debian
Type of work:
Wait
Blueprint:
Starter:
Affected tool:

Description

We need Debian bug #780610 resolved. Then rewrite commit:eb4abc9 in test/9062-otr-bot-with-python-potr appropriately.

Associated revisions

Revision 10ac45cd (diff)
Added by intrigeri over 4 years ago

Test suite: use convertkey from the (backported to Jessie) Debian package.

And then: drop our own copy of that script, and adjust setup documentation
accordingly.

Will-fix: #9066

Revision 91f91b53
Added by anonym over 4 years ago

Merge remote-tracking branch 'origin/test/9066-use-convertkey-from-Debian' into stable

Fix-committed: #9066

History

#1 Updated by intrigeri over 4 years ago

  • Target version: Tails_1.3.1

This won't happen (in a way that allows us to actually use the updated package in our test suite) before 1. Jessie is released (so that jessie-backports opens its doors) and 2. #8165 is resolved. So it's very unlikely that we have all that for 1.3.1.

=> please mark this as blocked by #8165, and adjust the target version accordingly. Hint: my current best bet is that Jessie will be out at some point in April.

#2 Updated by anonym over 4 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4

intrigeri wrote:

  • Target version: Tails_1.3.1

This won't happen (in a way that allows us to actually use the updated package in our test suite) before 1. Jessie is released (so that jessie-backports opens its doors)

Is it because this is not an important bug enough to break the freeze?

and 2. #8165 is resolved. So it's very unlikely that we have all that for 1.3.1.
=> please mark this as blocked by #8165, and adjust the target version accordingly.

This I don't understand. We have a temporary fix for the problem that works on both Wheezy (+ wheezy-backports) and Jessie, so how is it blocking #8165?

Hint: my current best bet is that Jessie will be out at some point in April.

Woo! Setting the milestone to 1.4 (2015-05-19) then.

#3 Updated by intrigeri over 4 years ago

  • Subject changed from Include convertkey.sh in python-potr to Use convertkey.py from the python-potr package
  • Parent task deleted (#9062)

This doesn't block #9062 anymore, so reparenting.

#4 Updated by anonym over 4 years ago

anonym wrote:

intrigeri wrote:

This won't happen (in a way that allows us to actually use the updated package in our test suite) before 1. Jessie is released (so that jessie-backports opens its doors)

Is it because this is not an important bug enough to break the freeze?

Forgot to ask: and since it's a bug that even violates the package description, won't the fix end up in Jessie's python-potr?

#5 Updated by intrigeri over 4 years ago

This won't happen (in a way that allows us to actually use the updated package in our test suite) before 1. Jessie is released (so that jessie-backports opens its doors)

Is it because this is not an important bug enough to break the freeze?

Exactly.

and 2. #8165 is resolved. So it's very unlikely that we have all that for 1.3.1. => please mark this as blocked by #8165, and adjust the target version accordingly.

This I don't understand. We have a temporary fix for the problem that works on both Wheezy (+ wheezy-backports) and Jessie, so how is it blocking #8165?

This is not blocking #8165, it is blocked by #8165 for the reasons stated above.

#6 Updated by intrigeri over 4 years ago

Forgot to ask: and since it's a bug that even violates the package description, won't the fix end up in Jessie's python-potr?

I strongly doubt it: I suspect this bug has been there since the initial package upload two years ago, and nobody complained about it. Now, of course it could be argued that violating the package's description is RC, or that the package description being wrong is RC. Not sure it would work, and not sure it's less work than maintaining a backport. It can also be argued that introducing a new script now may make the package more buggy than it currently is, in case the script itself is buggy.

In any case, I personally don't feel like adding to the release team's workload for that minor an issue, this late in the release process.

#7 Updated by intrigeri over 4 years ago

  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_1.4 to Tails_1.4.1
  • Type of work changed from Wait to Debian

Pinged on the Debian bug, proposing a solution + NMU. ETOOLAZY to create child tickets to track the status in Debian, and oh well, this should have been done initially anyway, so I won't bother. I'll reassign to anonym when it's fixed in Debian, or when I get bored.

#8 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Proposed a patch and expressed my intent to NMU.

#9 Updated by intrigeri over 4 years ago

  • % Done changed from 10 to 20
  • Type of work changed from Debian to Wait

NMU'ed. I'll now wait for the package to enter testing, and then will look into backporting it for Jessie so that we can use it in our test suite.

#10 Updated by intrigeri over 4 years ago

  • % Done changed from 20 to 30

Entered testing, asked the maintainer if he has plans to upload to jessie-backports, or if I may do it myself.

#11 Updated by intrigeri over 4 years ago

  • Type of work changed from Wait to Debian

Maintainer replied => I'll do the backport myself.

#13 Updated by intrigeri over 4 years ago

  • % Done changed from 30 to 40
  • Feature Branch set to test/9066-use-convertkey-from-Debian
  • Type of work changed from Debian to Wait

Backport uploaded, let's now wait for it to get out of NEW.

#14 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 40 to 50
  • QA Check set to Ready for QA

Entered jessie-backports => please review'n'merge.

#15 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#16 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#17 Updated by intrigeri about 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF