Project

General

Profile

Bug #9053

syslinux/ldlinux.c32 differs from installation source to destination on Jessie

Added by intrigeri over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
03/14/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

Spotted by the automated test suite:

call returned: [1, "Files /lib/live/mount/medium/isolinux/ldlinux.c32 and /mnt/new/syslinux/ldlinux.c32 differ\n", ""]

The original one has e.g. the "GCC: (Debian 4.9.2-10)" string, while the one installed on the target device has "GCC: (Debian 4.9.2-9)" instead.

That file is among the four ones that have a more recent mtime (that matches the installation time) on the destination than on the source: syslinux.cfg, stdmenu.cfg, ldlinux.sys and ldlinux.c32 => perhaps it's modified when we run syslinux, just like ldlinux.sys is? If so, then it should be added to ignores in usb.rb.


Related issues

Blocks Tails - Feature #7563: Update the automated test suite for Jessie ISO images Resolved 11/26/2014 01/15/2016

Associated revisions

Revision fe37010f (diff)
Added by intrigeri over 4 years ago

Add ldlinux.c32 to the list of bootloader files that are expected to be modified when we run syslinux.

Will-fix: #9053

History

#1 Updated by intrigeri over 4 years ago

  • Description updated (diff)

#2 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress

#3 Updated by intrigeri over 4 years ago

  • Assignee set to anonym
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

The way I understand http://www.syslinux.org/wiki/index.php/Library_modules#All_Syslinux_variants_need_an_additional_ldlinux_module, this seems to be entirely normal => added to the ignores list. anonym, may you please have a look and close this ticket if happy with it?

#4 Updated by intrigeri over 4 years ago

  • Blocks Feature #7563: Update the automated test suite for Jessie ISO images added

#5 Updated by anonym over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

The way I understand http://www.syslinux.org/wiki/index.php/Library_modules#All_Syslinux_variants_need_an_additional_ldlinux_module, this seems to be entirely normal => added to the ignores list. anonym, may you please have a look and close this ticket if happy with it?

Given that information, adding ldlinux.c32 to ignores makes sense. Closing ticket.

Also available in: Atom PDF