Project

General

Profile

Bug #9044

Chromebook C720-2800 requires tweaks to boot properly

Added by emmapeel over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
03/10/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/9044-syslinux-on-chromebooks
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Reported by user, hardware related:

The Chromebook is 64 bits, but when booting from vmlinuz2/initrd2.img is not booting (restarts some seconds after boot screen)

Changing vmlinuz2/initrd2.img to vmlinuz and initrd on the boot menu makes it boot.

Associated revisions

Revision df0275a4 (diff)
Added by intrigeri over 4 years ago

Install our custom syslinux package.

Will-fix: #9044

Revision a16f7efb (diff)
Added by intrigeri over 4 years ago

Install our custom isolinux package as well.

Will-fix: #9044

Revision 7142f681
Added by anonym over 4 years ago

Merge remote-tracking branch 'origin/bugfix/9044-syslinux-on-chromebooks' into devel

Fix-committed: #9044

History

#1 Updated by intrigeri over 4 years ago

  • Subject changed from Chromebook C720-2800 tries to boot with wrong image to Chromebook C720-2800 requires tweaks to boot properly
  • Assignee set to emmapeel
  • Target version changed from Tails_1.3 to Tails_1.3.2
  • QA Check set to Info Needed

Some Chromebooks need something like mem=1500m to boot properly, as discussed a few months ago (possibly without any conclusion reached, nor action taken to document it) on our support mailing-list. Is it the case for that one? I suspect the 32-bit kernel boots (as opposed to the 64-bit one) simply because it doesn't recognize all the available RAM, or similar.

(Also, please don't set "Target version" to a release that's already out -- thanks :)

#2 Updated by BitingBird over 4 years ago

This should be added to the know issues, it's currently not listed.

#3 Updated by intrigeri over 4 years ago

This should be added to the know issues, it's currently not listed.

Indeed, we've removed it with b793bc1 since we were told that it wasn't needed anymore. But since then we've had a few reports that some mem= parameter was needed.

#4 Updated by BitingBird over 4 years ago

Maybe we could just revert this commit and see if we still get reports?

#5 Updated by intrigeri over 4 years ago

Maybe we could just revert this commit and see if we still get reports?

That would be a good start. I suspect the entry in known issues should be made a bit more generic, because the workaround is apparently needed for various kinds of Chromebooks. That's frontdesk job.

Frontdesk: bonus points if you look into your tails-support@ archives to dig the useful information, pointers and testing reports we've gathered about this some months ago.

#6 Updated by intrigeri over 4 years ago

This might actually be caused by a bug in syslinux:

A patch was proposed upstream, applied in Ubuntu, and then proposed to Debian.

emmapeel, assuming I publish an ISO with that patch applied, will you be able to ask the bug reporter to test it?

#7 Updated by mercedes508 over 4 years ago

I might ask at least one user to try that ISO.

#8 Updated by BitingBird over 4 years ago

  • Assignee changed from emmapeel to intrigeri
  • QA Check deleted (Info Needed)

#9 Updated by emmapeel over 4 years ago

intrigeri wrote:

A patch was proposed upstream, applied in Ubuntu, and then proposed to Debian.

emmapeel, assuming I publish an ISO with that patch applied, will you be able to ask the bug reporter to test it?

sure! he seemed prone to tinkering...

#10 Updated by emmapeel over 4 years ago

intrigeri wrote:

A patch was proposed upstream, applied in Ubuntu, and then proposed to Debian.

emmapeel, assuming I publish an ISO with that patch applied, will you be able to ask the bug reporter to test it?

sure! user seemed prone to tinkering...

#11 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress

#12 Updated by intrigeri over 4 years ago

  • % Done changed from 0 to 10

#14 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to mercedes508
  • QA Check set to Info Needed

The latest Tails/Jessie experimental nightly build has the syslinux patch => please ask affected users to try it and report back. Thanks!

#15 Updated by mercedes508 over 4 years ago

  • Assignee changed from mercedes508 to intrigeri

The only user I could ask to test that image reported that it works fine.

#16 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4
  • QA Check deleted (Info Needed)

I'll probably won't have time to deal with that for 1.3.2. Also, I'd like to give a little bit more time to upstream to comment on the proposed patch (applied by Ubuntu and in Tails/Jessie, but not in Debian nor upstream yet).

#17 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#18 Updated by anonym over 4 years ago

  • Assignee set to intrigeri
  • QA Check changed from Ready for QA to Info Needed
  • Feature Branch set to bugfix/9044-syslinux-on-chromebooks

See review'n'merge request thread on tails-dev@.

#19 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Info Needed to Ready for QA

#20 Updated by anonym over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#21 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#22 Updated by BitingBird over 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF