Project

General

Profile

Bug #9034

tails-unblock-network calls undefined log function

Added by intrigeri almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Spoof MAC
Target version:
Start date:
03/07/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/9034-remove-useless-logging
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

If the blacklist couldn't be removed, it tries to call log, which doesn't exist in POSIX shell. Of course there are very little chances that this happens given we rm -f it just before, so I wonder if it's worth making this script any more complex by sourcing the relevant library file -- perhaps we could just drop the check.

Associated revisions

Revision db77e5b0 (diff)
Added by anonym over 4 years ago

Remove useless log() instance (Will-fix: #9034).

We haven't sourced the Tails shell library's loggin module, so log()
is undefined. Since we `rm -f` the file, log():ing if it still exists
afterwards should be pointless, so let's just not do it all.

Revision f4f6fa6f
Added by intrigeri over 4 years ago

Merge remote-tracking branch 'origin/bugfix/9034-remove-useless-logging' into stable

Fix-committed: #9034

History

#1 Updated by anonym over 4 years ago

  • Status changed from Confirmed to In Progress

#2 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/9034-remove-useless-logging

#3 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

#4 Updated by intrigeri over 4 years ago

  • % Done changed from 50 to 60

Passes code review.

#5 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

#6 Updated by BitingBird over 4 years ago

  • QA Check changed from Ready for QA to Pass

#7 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)

#8 Updated by BitingBird over 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF