Project

General

Profile

Bug #8902

The Unsafe Browser can't start anymore unless NM got exactly one nameserver

Added by shrineofyourlies almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
02/14/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/8902-unsafe-browser-vs-nm-nameservers
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

I upgraded to the Tails 1.3~rc1 image via the instructions listed on the relevant blog post. Since upgrading, I have attempted to launch the clearnet browser, via both the GUI and via terminal, and I am shown this error:
"unsafe-browser: error: NetworkManager passed us garbage data when trying to deduce the clearnet DNS server."

I have Tor Browser running at the same time fed by my computer's built-in WiFi card.

Associated revisions

Revision 9ccd3344 (diff)
Added by Tails developers almost 5 years ago

Allow zero or more DNS servers set by NetworkManager (Will-fix: #8902).

According to NetworkManager(8) IP4_NAMESERVERS is a space separated
list.

Revision e9686e2c
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'origin/bugfix/8902-unsafe-browser-vs-nm-nameservers' into testing

Fix-committed: #8902

History

#1 Updated by intrigeri almost 5 years ago

  • Assignee set to anonym
  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.3
  • Type of work changed from Discuss to Code
  • Affected tool set to Unsafe Browser

anonym, this looks like a regression caused by the stricter parsing of whatever we get from NM. May you please ask whatever additional info you need to the reporter?

#2 Updated by mercedes508 almost 5 years ago

  • Status changed from New to Rejected

I wanst' able to reproduce it, so no bug to me.

#3 Updated by intrigeri almost 5 years ago

  • Status changed from Rejected to New

mercedes508: the fact that the data sent by your own DHCP server doesn't trigger this bug doesn't mean it doesn't exist. As said in previous comment, I can see why there could be a regression in this area. We have release candidates precisely to identify such regressions.

#4 Updated by Tails almost 5 years ago

  • Status changed from New to In Progress

Applied in changeset commit:d29bdd13cf8da88589cace4863d8cbb064d9ec45.

#5 Updated by anonym almost 5 years ago

  • Assignee deleted (anonym)
  • Feature Branch set to bugfix/8902-unsafe-browser-vs-nm-nameservers

intrigeri wrote:

anonym, this looks like a regression caused by the stricter parsing of whatever we get from NM. May you please ask whatever additional info you need to the reporter?

Sure. shrineofyourlies, can you please reproduce the error, and then give us the contents of the file /var/lib/NetworkManager/env.

I have a pretty good guess what the issue is, though. Currently that file has to match the regex: "^IP4_NAMESERVERS=\"${IP4_REGEX}\"$" so only one DNS server is allowed. However, according to NetworkManager(8), "IP4_NAMESERVERS contains a space-separated list of the DNS servers", so we need to allow zero or more. We should allow zero, because that would still be valid (at least not garbage) and we would deal with it appropriately later any way.

I've pushed a branch which fixes this, but I guess we should wait with merging it until shrineofyourlies has answered.

#6 Updated by intrigeri almost 5 years ago

  • Assignee set to intrigeri
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA

Going to review and merge this, and then I'll ask shrineofyourlies to test the resulting nightly built ISO.

#7 Updated by intrigeri almost 5 years ago

  • Subject changed from Clearnet browser won't launch [1.3~rc1] to The Unsafe Browser can't start anymore unless NM got exactly one nameserver

#8 Updated by Tails almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 30 to 100

Applied in changeset commit:65fcba7107e99b036d909ba0add9b37186fbafee.

#9 Updated by intrigeri almost 5 years ago

  • % Done changed from 100 to 30

Manually tested with 1 and 2 nameservers in /var/lib/NetworkManager/env, looks good so merged. Now running the unsafe_browser, windows_camouflage and firewall_leaks automated tests.

#10 Updated by anonym almost 5 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 30 to 0
  • QA Check deleted (Ready for QA)

FTR, I tried pinging the user via email, but the given email address was apparently fake (got a "5.1.1 ... Recipient address rejected: User unknown").

#11 Updated by intrigeri almost 5 years ago

  • % Done changed from 0 to 100

#12 Updated by shrineofyourlies almost 5 years ago

my apologies for the email issue. i see that you've managed to fix it, and i thank you for doing so.

if it's any help to further the fix, here's the contents of the requested file, redacted for security:

amnesia@amnesia:~$ cat /var/lib/NetworkManager/env
IP4_NAMESERVERS="192.168.0.1 xxx.xxx.202.166"

#13 Updated by BitingBird almost 5 years ago

  • QA Check set to Pass

#14 Updated by BitingBird almost 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF