Project

General

Profile

Bug #8881

Explain how to access HD when it's a LVM volume

Added by BitingBird over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
02/08/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

doc/encryption_and_privacy/your_data_wont_be_saved_unless_explicitly_asked.mdwn -> the note about LVM being "more complicated" could be explained.

Pertinent discussion from #5636:

Regarding LVM, what happens by default?

-> Nothing useful when a PV appears (e.g. after unlocking a dm-crypt volume that hosts a PV).

what happens if you run vgchange -ay?

-> Then the VG and all LVs in there appear. Maybe they can even be mounted from GNOME Disks (not sure).


Related issues

Related to Tails - Feature #8949: Rework /doc/encryption_and_privacy/your_data_wont_be_saved_unless_explicitly_asked Confirmed 02/24/2015
Blocked by Tails - Feature #5636: Document how to access internal hard disks Resolved

History

#1 Updated by BitingBird over 4 years ago

  • Blocked by Feature #5636: Document how to access internal hard disks added

#2 Updated by sajolida over 4 years ago

A bit more testing would be required to be sure how Tails behaves. Then if we think this is outside of our goals we could point to external doc maybe.

#3 Updated by BitingBird over 4 years ago

  • Priority changed from Normal to Low

#4 Updated by emmapeel over 4 years ago

Maybe this bug can be closed? I can read an explanation to open LVMs at

https://tails.boum.org/doc/encryption_and_privacy/your_data_wont_be_saved_unless_explicitly_asked/

I don't think we need to add the whole process as the Disk Utility GUI is quite simple, where you need to:

- Unlock the device
- Start the Volume
- Mount it

Is the bug open because this information is supposed to go there? I think it may be too much for that page...

#5 Updated by emmapeel over 4 years ago

  • Related to Feature #8949: Rework /doc/encryption_and_privacy/your_data_wont_be_saved_unless_explicitly_asked added

#6 Updated by emmapeel over 4 years ago

  • QA Check set to Ready for QA

#7 Updated by sajolida over 4 years ago

  • Assignee set to BitingBird
  • QA Check changed from Ready for QA to Info Needed

Yeah, what's in https://tails.boum.org/doc/encryption_and_privacy/your_data_wont_be_saved_unless_explicitly_asked/ is fine with me. Maybe we forgot with BitingBird to close this ticket as well when working on a related one... BitingBird can you check as you wrote that note (if I remember correctly)?

#8 Updated by BitingBird over 4 years ago

  • Assignee deleted (BitingBird)
  • QA Check deleted (Info Needed)

I didn't know the exact steps that emmapeel listed in comment 4, so I couldn't document it then. I still think it would be useful to add them to the page, don't you think?

#9 Updated by BitingBird over 4 years ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

#10 Updated by sajolida about 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

I think that the page is fine as it is. If you want to be sure about that, then I suggest you try to open the encrypted Debian system on your internal hard disk from Tails and see how it goes. Then feel free to reopen this ticket if you think that's not easy enough and makes sense as part of our doc.

Also available in: Atom PDF