Project

General

Profile

Feature #8864

Consider flagging first boot after installing

Added by sajolida about 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
02/04/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:
Installer

Description

That would be useful to take people by the hand and go forward with either:

  • Clone temporary Tails to minimal Tails.
  • Upgrading back their original device.
  • Configuring persistence.

Related issues

Related to Tails - Feature #14534: Improve UX when Wi-Fi is not working Confirmed 12/29/2017

History

#1 Updated by sajolida about 5 years ago

  • Description updated (diff)

#2 Updated by sajolida almost 5 years ago

Note that proposing to clone a temporary Tails comes in different scenarios than configuring persistence. Actually both options are self-exclusive. If ever we can detect that a device is a temporary Tails we could instead start Tails Installer directly (or even lock other usages) as suggested by Lunar in https://mailman.boum.org/pipermail/tails-ux/2015-May/000388.html.

#3 Updated by intrigeri over 4 years ago

  • Assignee set to sajolida
  • QA Check set to Ready for QA

Report from the monthly meeting:

"We tried to answer this question: "is it OK that a given Tails device
has written, somewhere, whether it has been started already?"

a) if I root your Tails, what does it give me to know whether it's the
first time it's booted?

and

b) if I steal your Tails, what does it give me to know whether it's been started yet?

and we didn't find any serious risks in doing so, except it proves
that a given Tails device has been used (which might entail more
legal risks than mere possession), which seemed overkill a threat
model to us."

=> sajolida, I guess you'll want to do what you want with this outcome, on Redmine or elsewhere :)

#4 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

I don't think there's nothing in our roadmap that relies on this. But now that we have this decision it could allow us to propose to advertise better persistence. But I don't think we have this idea tracked anywhere, so I'm marking this as resolved.

#5 Updated by intrigeri about 4 years ago

I don't know where to write this since there is apparently no follow-up to the discussion we had, but still: https://www.chromium.org/chromium-os/chromiumos-design-docs/disk-format documents exactly how they do it with the 64-bit Attributes field that any GPT partition entry has, so it should be pretty easy.

#6 Updated by intrigeri about 1 year ago

  • Related to Feature #14534: Improve UX when Wi-Fi is not working added

Also available in: Atom PDF