Project

General

Profile

Feature #8850

Bug #7552: Firefox extension to automatically verify the ISO checksum

Bug #6851: Fix ISO verification using checksum

Feature #8849: Technical specifications for ISO verification extension

Investigate feasibility of OpenPGP signature verification in JavaScript

Added by sajolida over 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
02/04/2015
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
ISO Verification Extension

History

#1 Updated by sajolida over 4 years ago

  • Subject changed from Investigate feasibility of OpenPGP signature verification in extension to Investigate feasibility of OpenPGP signature verification in JavaScript
  • Affected tool set to ISO Verification Extension

#2 Updated by sajolida over 4 years ago

  • Blocks Feature #8873: Decide which kind of verification would the ISO verification extension do added

#3 Updated by sajolida over 4 years ago

  • Priority changed from Normal to Elevated

#4 Updated by sajolida over 4 years ago

Reference implementation in JS seems to be http://openpgpjs.org/ which is quite actively developped (https://github.com/openpgpjs/openpgpjs) which is used by Mailvelope and GMail-crypt. GMail End-to-End also wrote one from scratch (https://github.com/google/end-to-end).

#5 Updated by sajolida about 4 years ago

I think that we won't probably have to do this, see https://labs.riseup.net/code/issues/8873#note-4.

#6 Updated by sajolida about 4 years ago

  • Assignee deleted (sajolida)

#7 Updated by sajolida about 4 years ago

  • Blocks deleted (Feature #8873: Decide which kind of verification would the ISO verification extension do)

#8 Updated by sajolida about 4 years ago

  • Priority changed from Elevated to Normal

We won't do OpenPGP in the extension.

#9 Updated by sajolida about 4 years ago

  • Status changed from Confirmed to Rejected

Also available in: Atom PDF