Project

General

Profile

Feature #8802

Feature #10552: Assistant: Write "Upgrade command line" scenario

Feature #8581: Analyse and simplify the installation and upgrade workflows

Feature #8583: Rework the installation process and scenarios

Investigate graphical tools for manual installation on Mac

Added by sajolida over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
-
Start date:
02/04/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

Once we get Tails Installer into Debian, Mac users without a DVD would be the last ones to have to go through the command line instructions.

Furthermore, new models of MacBook Pro, and even iMac don't have DVD drive anymore. MacBook Air never had one to beginning with.


Subtasks


Related issues

Related to Tails - Feature #8560: Study feasibility of porting Tails Installer to OS X Rejected 01/06/2015
Related to Tails - Bug #11348: Test Etcher, a multiplatform USB stick burner Resolved 04/14/2016
Related to Tails - Bug #11668: Install on Mac: test Entreprise Rejected 08/19/2016
Related to Tails - Feature #11682: Document Etcher to install Tails from macOS Resolved 08/20/2016

History

#1 Updated by sajolida over 4 years ago

  • Related to Feature #8560: Study feasibility of porting Tails Installer to OS X added

#2 Updated by intrigeri over 4 years ago

(Posting again on the correct ticket.) I've been told that diskutil (sic?) on OSX allows one to do the same thing as dd, but in a GUI. Once we ship a hybrid ISO, this means the bootstrap can be done without the command line, and in turn this very ticket becomes not so much of an emergency as it currently seems to be.

#4 Updated by sajolida over 4 years ago

I tried Disk Utility and it doesn't work with our ISO (even isohybrid). It returns "Could not validate source". Apparently Mac only accept some format of ISO images, as explained on:

#5 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to Resolved

I'm afraid there are none :(

#6 Updated by intrigeri over 4 years ago

We're told that Rufus 2.0 worked for someone

#7 Updated by sajolida over 4 years ago

  • Affected tool set to Installation Assistant

#8 Updated by sajolida over 4 years ago

  • Assignee deleted (tchou)

#9 Updated by mercedes508 over 3 years ago

  • Status changed from Resolved to Confirmed
  • Assignee set to sajolida

I'm not sure this is relevant anymore, but I tried those three tools:

And my results are (using USB and a Tail-2.0 iso):

  • UNetbootin: the USB wasn't recognized by the software even though it was formatted in FAT32
  • Mac Linux USB Loader: installed Tails in a strange way, wasn't able to clone&install on another USB
  • RPi-sd card builder: worked fine, very simple. But need to be modified, it only advertises for SD card and the translation isn't all good (in english), and it looks dedicated to Rasperry Pi. But it went fine installing Tails 2.0 on a USB, and then cloning&installing it on another USB which worked as well.

#10 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

Thanks for all the investigation! So the only one that works is RPi-sd card builder which is a "closed source application which requires your root password" according to http://elinux.org/RPi_Easy_SD_Card_Setup#Run_an_App_.28Only_with_graphical_interface.29.

The same page also mentions Pi Filler which is open source but not available after Yosemite, so not a solution either.

Still, seeing these tiny apps for Mac it gives a bit of hope that doing a graphical equivalent of `dd` on Mac sounds relatively easy to do.

#11 Updated by kaboum over 3 years ago

Hey,
It is maybe a bit late but did you try this: http://www.etcher.io/
I didn't tested on mac but it looks easy, has a good UI AND is open-source.

#12 Updated by sajolida over 3 years ago

  • Related to Bug #11348: Test Etcher, a multiplatform USB stick burner added

#13 Updated by sajolida over 3 years ago

Thanks for the link! I created #11348 to test it. I'm not sure we should reopen this ticket every time we find a new candidate, that's why I created a different ticket. It would be super cool if you tested it. Do you want me to assign #11348 to you?

#14 Updated by kaboum over 3 years ago

Yes, please do it. I fon't know if I will succes to find a Mac but I'll try.

#15 Updated by mercedes508 over 3 years ago

  • Status changed from Resolved to Confirmed
  • Assignee set to mercedes508
  • Type of work changed from Research to Test

I assigned it to me, because I have a mac to test it.

Cheers.

#16 Updated by sajolida over 3 years ago

  • Related to deleted (Bug #11348: Test Etcher, a multiplatform USB stick burner)

#17 Updated by sajolida over 3 years ago

  • Related to Bug #11348: Test Etcher, a multiplatform USB stick burner added

#18 Updated by mercedes508 over 3 years ago

  • Assignee changed from mercedes508 to sajolida
  • Type of work changed from Test to Research

Hi,

I tested it but some other folks already did it according to #11348

#19 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

Closing this ticket again and "investigate" has been done again.

#20 Updated by elouann about 3 years ago

  • Related to Bug #11668: Install on Mac: test Entreprise added

#21 Updated by intrigeri almost 2 years ago

  • Related to Feature #11682: Document Etcher to install Tails from macOS added

Also available in: Atom PDF