Project

General

Profile

Bug #8756

config/chroot_local-packages feature is broken

Added by intrigeri about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
01/21/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/8756-repair-local-packages
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The config/chroot_local-packages feature is broken, and seems to have been since config/binary_local-hooks/40-include_syslinux_in_ISO_filesystem was introduced. This can be painful e.g. for contributors who haven't write access to our APT repository.


Related issues

Copied to Tails - Bug #8910: config/chroot_local-packages feature is broken by 19-install-tor-browser-AppArmor-profile Resolved 02/16/2015

Associated revisions

Revision 64adfc7d (diff)
Added by Tails developers about 5 years ago

Don't attempt to retrieve source packages from local-packages (Will-Fix: #8756).

live-build does not include source packages in the index of locally available
packages. This makes since, since we don't include deb-src lines for other
repositories. And then, as reported on
https://labs.riseup.net/code/issues/8724#note-12, whenever ones uses the
config/chroot_local-packages feature, the build fails.

Therefore, when we generate temporary deb-src entries, skip the repository that
indexes locally available packages. This should only be problematic if one wants
to provide the syslinux source package there, which is unlikely, and in any case
way less important than repairing config/chroot_local-packages for the general
case (binary packages).

Revision 1d8e9f01
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'origin/bugfix/8756-repair-local-packages' into devel

Fix-committed: #8756

History

#1 Updated by Tails about 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:83870408f42da246fd64f5c11b79275d802c1991.

#2 Updated by intrigeri about 5 years ago

  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/8756-repair-local-packages

#3 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to alant
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Alan, want to take this review, since you discovered the bug?

#4 Updated by alant almost 5 years ago

  • Assignee deleted (alant)

intrigeri wrote:

Alan, want to take this review, since you discovered the bug?

I think there is a mistake in the commit message: "This makes since, since we don't include deb-src lines for other repositories." should be read "This makes sense, since...", no?

Else, it looks good. However, I have not a good enough Internet connection to test that. Please do it.

Side note: with the bad conection I have access to currntly, the build always break at config/binary_local-hooks/40-include_syslinux_in_ISO_filesystem while downloading sources.

#5 Updated by intrigeri almost 5 years ago

  • Assignee set to anonym
  • % Done changed from 50 to 60

alant wrote:

I think there is a mistake in the commit message: "This makes since, since we don't include deb-src lines for other repositories." should be read "This makes sense, since...", no?

Right.

Else, it looks good. However, I have not a good enough Internet connection to test that. Please do it.

Thanks. Reassigning to the RM, then.

#6 Updated by Tails almost 5 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

Applied in changeset commit:9c78a901531d22b7b021a6fa4ffe302e4a8df8b7.

#7 Updated by anonym almost 5 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#8 Updated by kytv almost 5 years ago

  • Status changed from 11 to Confirmed
  • Assignee set to intrigeri
  • QA Check changed from Pass to Dev Needed

Unfortunately, I don't think this is fixed yet, or perhaps I hit a different bug.

In the testing branch, I added config/chroot_local-packages/i2p_0.9.17-3_all.deb (my apparmor-enabled test package for #7724) and started a build. It failed with:

Get:1 Downloading iceweasel-l10n-zh-cn 1:31.4.0esr-1~deb7u1 [460 kB]
Fetched 460 kB in 0s (9333 kB/s)
Removing unwanted browser search plugins
Overriding TBB branding with our own
Setting up localized browser search plugins
Generating Tor Browser profile
Creating symbolic link for potentially persistent browser bookmarks
Configuring I2P
Removing traces of the nameservers used when building
Tweaking the offline website's CSS
Installing AppArmor profile for Tor Browser
Get:1 file: ./ Release.gpg [316 B]
Get:2 file: ./ Release [1232 B]
Hit http://deb.torproject.org obfs4proxy Release.gpg
Hit http://security.debian.org wheezy/updates Release.gpg

[......................snipped.....................]

Get:21 http://ftp.us.debian.org testing/contrib Sources [51.5 kB]
Get:22 http://ftp.us.debian.org testing/non-free Sources [100 kB]
Fetched 22.5 MB in 34s (646 kB/s)
W: Failed to fetch file:/root/local-packages/./Release  Unable to find expected entry 'Sources' in Release file (Wrong sources.list entry or malformed fil
e)

E: Some index files failed to download. They have been ignored, or old ones used instead.
E: config/chroot_local-hooks/19-install-tor-browser-AppArmor-profile failed (exit non-zero). You should check for errors.
P: Begin unmounting filesystems...

real    10m54.052s
user    7m9.180s
sys     1m56.072s
lb build failed (1).

#9 Updated by kytv almost 5 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • QA Check changed from Dev Needed to Pass

#10 Updated by kytv almost 5 years ago

  • Copied to Bug #8910: config/chroot_local-packages feature is broken by 19-install-tor-browser-AppArmor-profile added

Also available in: Atom PDF