Project

General

Profile

Bug #8747

The OpenPGP key for deb.tails.boum.org will expire soon

Added by kytv about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
01/20/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/8747-update-tails-apt-repo-signing-key
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

$ gpg --fingerprint 0xC7988EA7A358D82E
pub   4096R/0xC7988EA7A358D82E 2012-02-04 [expires: 2015-02-03]
      Key fingerprint = 221F 9A3C 6FA3 E09E 182E  060B C798 8EA7 A358 D82E
uid                            deb.tails.boum.org archive signing key

Related issues

Related to Tails - Bug #10419: The OpenPGP key for deb.tails.boum.org will expire soon Resolved 10/25/2015
Duplicated by Tails - Bug #8745: deb.tails.boum.org PGP key expires on 2015-02-03 Duplicate 01/19/2015 02/03/2015

Associated revisions

Revision e630cc81 (diff)
Added by Tails developers almost 5 years ago

Update deb.tails.boum.org apt repo signing key. (Will-fix: #8747)

Revision 424ff926
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'origin/bugfix/8747-update-tails-apt-repo-signing-key'

Closes: #8747.

History

#1 Updated by kytv about 5 years ago

  • Assignee set to bertagaz

#2 Updated by intrigeri about 5 years ago

  • Subject changed from The GPG key for deb.tails.boum.org will expire soon to The OpenPGP key for deb.tails.boum.org will expire soon
  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.3

#3 Updated by intrigeri almost 5 years ago

  • Duplicated by Bug #8745: deb.tails.boum.org PGP key expires on 2015-02-03 added

#4 Updated by Tails almost 5 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:bf52981123d6a19380ffea377d2f0cb168c8f0cb.

#5 Updated by bertagaz almost 5 years ago

  • Assignee changed from bertagaz to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to 8747-update-tails-apt-repo-signing-key

#6 Updated by bertagaz almost 5 years ago

Forgot to mention that I've already pushed the updated key to the keyservers network.

#7 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch changed from 8747-update-tails-apt-repo-signing-key to bugfix/8747-update-tails-apt-repo-signing-key

This branch seems to be based on devel. Given the key will expire before next release, I think it should be based on master, so that we can publish it live ASAP.

#8 Updated by Tails almost 5 years ago

Applied in changeset commit:fa7aafe72849ed9d9fbfe7adf2816596e52bcd61.

#9 Updated by bertagaz almost 5 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Pushed -f an updated branch based on master.

#10 Updated by Tails almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Applied in changeset commit:0b7ad062142ac9fb4229d6a83cf1674fffe0424a.

#11 Updated by intrigeri almost 5 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 100 to 80
  • QA Check changed from Ready for QA to Dev Needed

The secret key wasn't updated in the tails_secrets_apt Puppet module. I don't know how it was updated on apt.lizard, but if the Puppet module isn't up-to-date, surely we can't reproduce this part of our infra easily enough.

#12 Updated by bertagaz almost 5 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check changed from Dev Needed to Info Needed

Unless I'm wrong it has been updated in commit c09dd68. I might have pushed it in the afternoon or so, I don't remember.

#13 Updated by intrigeri almost 5 years ago

Unless I'm wrong it has been updated in commit c09dd68.

I see no such commit. What exact Git remote did you push it too? (answer in a private comment, maybe)

#14 Updated by bertagaz almost 5 years ago

  • QA Check changed from Info Needed to Ready for QA

intrigeri wrote:

I see no such commit. What exact Git remote did you push it too? (answer in a private comment, maybe)

Right, my bad, I've been too quick reading your reply and didn't catch the secret part of the question. Didn't remember the key was also in this repo.

Pushed it some mins ago.

#15 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 80 to 90

Seen it, thanks. I've just deployed it to lizard. Please close this ticket as resolved once you confirm Puppet has applied it successfully.

#16 Updated by bertagaz almost 5 years ago

  • Assignee changed from bertagaz to intrigeri

Seems to be deployed correctly on lizard.

#17 Updated by intrigeri almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Merged master into stable, devel, experimental.

#18 Updated by intrigeri almost 5 years ago

  • Assignee deleted (intrigeri)

#19 Updated by sajolida almost 5 years ago

Someone sent a report on tails-bugs@ that he couldn't manage to build according to the manual build instructions. Shall we merge this into master as well, just for the sake of completeness? I know this doesn't make much sense....

#20 Updated by intrigeri almost 5 years ago

Someone sent a report on tails-bugs@ that he couldn't manage to build according to
the manual build instructions. Shall we merge this into master as well, just for the
sake of completeness? I know this doesn't make much sense....

It's been merged into master a while ago. No?

#21 Updated by kytv almost 5 years ago

  • QA Check changed from Ready for QA to Pass

#22 Updated by bertagaz about 4 years ago

  • Related to Bug #10419: The OpenPGP key for deb.tails.boum.org will expire soon added

Also available in: Atom PDF