Project

General

Profile

Feature #8735

Feature #8222: Transition to a new signing key

Feature #8740: Transition to a new signing key, phase 2

Stop shipping our old signing key in the ISO

Added by intrigeri about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
01/19/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

We can do that in 1.3.1, since we'll be in the final stage of the transition to our new signing key then. We should do that in 1.3.1, as we want Tails Upgrader to stop trusting the old signing key at that point.

Associated revisions

Revision 07cdca06 (diff)
Added by Tails developers about 5 years ago

Only ship our new signing key, adjust whatever is needed in our code.

Closes: #8735, #8736, #8882.

History

#1 Updated by intrigeri about 5 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2
  • Parent task changed from #8222 to #8740

#2 Updated by Tails about 5 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:431278bf882097258bba351754cacec139aa897d.

#3 Updated by BitingBird about 5 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.3.1

Also available in: Atom PDF